算法设计与分析 模拟考 radar installation

总时间限制: 
1000ms 
内存限制: 
65536kB
描述
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations
输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1
来源
Beijing 2002

计算每个点对应的圆心区间范围,之后贪心即可。

注意采用优先队列的时候需要使用结构体对于小于进行重载。


采用优先队列的写法:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <vector>
#include <algorithm>
#include <queue>
#include <math.h>

using namespace std;

int n;
int d;
int casenum;

typedef struct ra
{
    float l;
    float r;
    bool operator < (const ra& b) const
    {
        if(l == b.l) return r > b.r;
        else
            return l > b.l;
    }
}range;

priority_queue<ra> pq;

void getradis(int x, int y)
{
    range a;
    float t = sqrt(d * d - y * y);
    a.l = x - t;
    a.r = x + t;
    pq.push(a);
}

int getnum()
{
    int num = 0;
    while(!pq.empty())
    {
        num++;
        float radis = pq.top().r;
        pq.pop();
        while(!pq.empty())
        {
            range next = pq.top();
            if(next.l <= radis)
            {
                if(next.r >= radis)
                {
                    pq.pop();
                    continue;
                }
                else
                {
                    radis = next.r;
                    pq.pop();
                    continue;
                }
            }
            else
            {
                break;
            }
        }
    }
    return num;
}

int main()
{
    scanf("%d%d", &n, &d);
    while(n != 0 || d != 0)
    {
        casenum++;
        while(!pq.empty())
            pq.pop();
        bool flag = true;
        for(int i = 0; i < n; i++)
        {
            int x, y;
            scanf("%d%d", &x, &y);
            if(y <= d)
                getradis(x, y);
            else
                flag = false;
        }
        if(flag)
            printf("Case %d: %d\n", casenum, getnum());
        else
            printf("Case %d: %d\n", casenum, -1);
        scanf("%d%d", &n, &d);
    }
    return 0;
}


采用sort的写法:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <vector>
#include <algorithm>
#include <queue>
#include <math.h>

using namespace std;

int n;
int d;
int casenum;

/*typedef struct ra
{
    float l;
    float r;
    bool operator < (const ra& b) const
    {
        if(l == b.l) return r > b.r;
        else
            return l > b.l;
    }
}range;

priority_queue<ra> pq;

void getradis(int x, int y)
{
    range a;
    float t = sqrt(d * d - y * y);
    a.l = x - t;
    a.r = x + t;
    pq.push(a);
}

int getnum()
{
    int num = 0;
    while(!pq.empty())
    {
        num++;
        float radis = pq.top().r;
        pq.pop();
        while(!pq.empty())
        {
            range next = pq.top();
            if(next.l <= radis)
            {
                if(next.r >= radis)
                {
                    pq.pop();
                    continue;
                }
                else
                {
                    radis = next.r;
                    pq.pop();
                    continue;
                }
            }
            else
            {
                break;
            }
        }
    }
    return num;
}*/

vector< vector<float> > pq;

void getradis(int x, int y)
{
    vector<float> a;
    float t = sqrt(d * d - y * y);
    a.push_back(x - t);
    a.push_back(x + t);
    pq.push_back(a);
}

int getnum()
{
    int num = 0;
    for(int i = 0; i < pq.size(); ++num)
    {
        float center = pq[i++][1];
        while(i < pq.size())
        {
            if(pq[i][0] <= center)
            {
                if(pq[i][1] < center)
                {
                    center = pq[i][1];
                }
                i++;
            }
            else
                break;
        }
    }
    return num;
}

int main()
{
    scanf("%d%d", &n, &d);
    while(n != 0 || d != 0)
    {
        casenum++;
        pq.clear();
        bool flag = true;
        for(int i = 0; i < n; i++)
        {
            int x, y;
            scanf("%d%d", &x, &y);
            if(y <= d)
                getradis(x, y);
            else
                flag = false;
        }
        if(flag)
        {
            sort(pq.begin(), pq.end());
            printf("Case %d: %d\n", casenum, getnum());
        }
        else
            printf("Case %d: %d\n", casenum, -1);
        scanf("%d%d", &n, &d);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值