UVA 10706 Number Sequence

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2 … Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another. For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910
Input The first line of the input file contains a single integer t (1 ≤ t ≤ 25), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output
There should be one output line per test case containing the digit located in the position i.
Sample Input
2
8
3
Sample Output
2
2

这道题是HDU 1597的升级版,可以用二分做,这里使用数论,抛去所求数组前的无关数,缺点是需要变量太多,容易弄混。

#include<iostream>
#include<cmath>
using namespace std; 
long long N,b; 
int main() 
{      
    cin>>N;     
    while(N--)     
    {          
        cin>>b;         
        int group_max_count=1,group_long=1;      
        while(b>group_long)
        {
            group_max_count++;
            b-=group_long;
            int group_max_count2=group_max_count;
            while(group_max_count2>0)
            {
                group_max_count2/=10;
                group_long++;
            }
        }
        int j=1,m=9;
        while(b>m)
        {
            b=b-m;
            j++;
            m=j*9*pow(10.0,j-1);
        }//j是位数 b是它所在位数的个数
        int c=b/j,d;//c是位数集合中的位数 d是所在数的位数
        if(b%j!=0)
        {
            c++;
            d=j-b%j;
        }
        else
        {
            d=0;
        }
        int e=c+pow(10.0,j-1)-1;
        for(;d>0;d--)
        {
            e/=10;//所在数
        }
        cout<<e%10<<endl;
    }      
    return 0; 
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值