Doing Homework again HDU 1789 贪心?DP

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6840    Accepted Submission(s): 4072


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 

Author
lcy
  题意是,n个作业,每个作业有截止日期和对应的分数,到截止日期没有去做的话就会扣分,现在要找出一个方案使得扣分最少,输出扣分,
思路:一开始是想在可以做的作业中选取分数最大的,
---------WA  代码-------------------------------
#include<stdio.h>
#include<iostream>
#define maxn 1020
using namespace std;
int tian[maxn],fen[maxn],dp[maxn];
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int n;
		cin>>n;
		for(int i=1;i<=n;i++)
		{
			cin>>tian[i];
		}int sum=0;
		for(int j=1;j<=n;j++)
		{
			cin>>fen[j];
			sum+=fen[j];
		}
		fill(dp,dp+n+2,0);
		for(int i=1;i<=n;i++)
		{	int t=0;
			for(int j=1;j<=n;j++)
			{
				if(tian[j]>=i&&fen[j]>fen[t])
				{
					t=j;
				}
			}
			dp[i]=dp[i-1]+fen[t];
			tian[t]=-1;
		}
		cout<<sum-dp[n]<<endl;
	}
}
结果,没考虑到如果最大的那个作业做了,但是却放过了机会去做其他作业,而这些作业有可能加起来比分数大的还要大!


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值