hdu 1789 Doing Homework again 状态压缩DP

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8939    Accepted Submission(s): 5279


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 

Author
lcy
 

Source
 

Recommend
lcy

贪心、排序我不会,那么可以用动归。

既然课程比较少15个,可以用状态压缩。

每到一个状态之前必然计算过了,下面的代码中注意体会。

#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<climits>
#include<queue>
#include<vector>
#include<map>
#include<sstream>
#include<set>
#include<stack>
#include<utility>
//#pragma comment(linker, "/STACK:102400000,102400000")
#define PI 3.1415926535897932384626
#define eps 1e-10
#define sqr(x) ((x)*(x))
#define FOR0(i,n)  for(int i=0 ;i<(n) ;i++)
#define FOR1(i,n)  for(int i=1 ;i<=(n) ;i++)
#define FORD(i,n)  for(int i=(n) ;i>=0 ;i--)
#define  lson   num<<1,le,mid
#define rson    num<<1|1,mid+1,ri
#define MID   int mid=(le+ri)>>1
#define zero(x)((x>0? x:-x)<1e-15)

using namespace std;
const int INF =0x3f3f3f3f;
const int maxn= 15+3   ;
const int maxed= (1<<15)-1;
//const int maxm=    ;
//const int INF=    ;
typedef long long ll;
const ll inf =1000000000000000;//1e15;
//ifstream fin("input.txt");
//ofstream fout("output.txt");
//fin.close();
//fout.close();
//freopen("a.in","r",stdin);
//freopen("a.out","w",stdout);
int n;
int ed;
struct Course
{
    string name;
    int deadline;//截止日期
    int cost;//完成一门课程所花的时间
}  c[maxn];

struct kk
{
    int pre;//前一个状态(最优)
    int pcourse;//到达该状态的课程(最优)
    int bonu;//惩罚分数
    int time;//所花时间
}   dp[maxed+10];
bool vis[maxed+10];
void print(int sta)
{
    if(dp[sta].pre!=0)
    print( dp[sta].pre );

    int p=dp[sta].pcourse;

    cout<<  c[p].name<<endl;
}


int main()
{
  int T;scanf("%d",&T);
  while(T--)
  {
      scanf("%d",&n);
      ed=(1<<n)-1;
      memset(vis,0,sizeof vis);
      FOR0(i,n)
      {
          cin>>c[i].name;
          scanf("%d%d",&c[i].deadline,&c[i].cost);
      }

     dp[0].pre=-1;
     dp[0].bonu=0;
     dp[0].time=0;
     dp[0].pcourse=-1;
    vis[0]=1;
         for(int i=0;i<ed;i++   )
       {
               for(int j=0;j<n;j++)     //这样转移,可以保证每到一个状态,改状态已经计算过了
           {
              if(i & (1<< j ))  continue;
              int sta=   i|  (1<< j)  ;


               dp[sta].time=dp[i].time+c[j].cost;   //到达同一个状态,一共所花的时间是一样的。
               int b=  (dp[sta].time  -c[j].deadline>0)?dp[sta].time  -c[j].deadline:0;
              if(!vis[sta]  )
              {
                  vis[sta]=1;
                  dp[sta].pre=i;
                  dp[sta].pcourse=j;
                  dp[sta].bonu=dp[i].bonu+    b;
              }
              else
              {
                    if(dp[i].bonu+b<dp[sta].bonu)
                    {
                        dp[sta].bonu=dp[i].bonu+b;
                        dp[sta].pre=i;
                        dp[sta].pcourse=j;
                    }
              }
          }
      }
      printf("%d\n",dp[ed].bonu);
      print(ed);
  }

    return 0;
}



 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值