模板题之广度搜索 HDU2717 Catch That Cow

Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 很简单的思路,搜索最短路径,每次的选择都是三种,要找到最短的路径,显然BFS,废话不说,帖代码!
#include<cstdio>
#include<queue>
#include<iostream>
#include<string.h>
#define mnum 100001
using namespace std;
int vis[mnum],time[mnum];
int n,k;
void bfs()
{
	queue<int>q;
	q.push(n);
	while(!q.empty())
	{
		int cur=q.front();
		vis[cur]=1;q.pop();
		if(cur==k)
		{
			printf("%d\n",time[cur]);
			break;
		}
		else 
		{
			int t;int tm[3]={cur+1,cur-1,cur*2};
			for(int i=0;i<3;i++)
			{
				t=tm[i];
			if(t>=0&&t<=mnum-1&&vis[t]==0)
			{
				time[t]=time[cur]+1;
				vis[t]=1;  //注意这里vis[t]要设为一,意思是已经入队的地方就不要再入队了(因为最短路与回头路是矛盾的!)
				q.push(t);
			}
			}
		}
	}
}
int main()
{
	while(scanf("%d%d",&n,&k)!=EOF)
	{	memset(vis,0,sizeof(vis));
		memset(time,0,sizeof(time));
		bfs();
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值