问题:
Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).
Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").
FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.
Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.
Input
Line 1: Two space-separated integers: N and M
Line 2: This line contains exactly M characters which constitute the initial ID string
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.
Output
Line 1: A single line with a single integer that is the minimum cost to change the given name tag.
Sample Input
3 4 abcb a 1000 1100 b 350 700 c 200 800
Sample Output
900
Hint
If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.
大意:
开始两个数表示给定的字符的种类和字符串长度,然后是一个字符串,接着是给定字符和添加和删除的费用,你可以添加或删除任意给定的字符使之变成回文字符串,求变成回文数最小的花费。
思路:
#define N 2010
#include<stdio.h>
#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[N][N],s[30];
int n,m;
char k[N];
int main()
{
while(~scanf("%d%d",&n,&m))
{
scanf("%s",k);
memset(dp,0,sizeof(dp));
for(int i=0; i<n; i++)
{
int a,b;char c;getchar();
scanf("%c %d%d",&c,&a,&b);
s[c-'a']=min(a,b);//先比较好添加或删除那个更省钱
}
for(int i=1; i<m; i++)
for(int j=i-1; j>=0; j--)
{//状态迁移
dp[i][j]=min(dp[i-1][j]+s[k[i]-'a'],dp[i][j+1]+s[k[j]-'a']);
if(k[i]==k[j])
dp[i][j]=min(dp[i][j],dp[i-1][j+1]);
}
printf("%d\n",dp[m-1][0]);
}
return 0;
}
这是一个区间dp问题,我们可以假设dp[ i ][ j ] 是j -> i 区间字符串变成回文字符串的最小花费,dp[ i ][ j ]是由dp[ i-1 ][ j ]和dp[ i ][ j+1 ] 两种状态迁移过来的,这两个状态是已经求出的,所以直接在这两种状态的端点添加或删除字符变为dp[ i ][ j ]状态就好了,还有就是当k[ i ]==k[ j ] 时,两端点已经相等dp[ i ][ j ]==min(dp[ i ][ j ],dp[ i-1 ][ j+1 ]).
代码: