Wormholes POJ - 3259

问题:

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. MW+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from S to E that also moves the traveler backT seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

大意:

开始三个数为n,s,w,表示John有n个农场,所有农场之间共有s条路,w个虫洞,然后接下来s行表示两个农场之间来往需要的时间t,接着是w行表示两个农场之间有个虫洞,但虫洞是单向的(虫洞可以使时光倒流)通过虫洞到另一个农场的时间是-t。问John能否通过一个路线使他可以在一个农场遇到自己。

思路:

这个题是让你用Bellman-Ford算法判断是否存在负权回路的模板题。路是双向导通的正权路,虫洞看成单向导通的负权路。

#define N 20000
#define inf 0x3f3f3f
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int u[N],v[N],w[N],dis[550];
int n,s,t;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int l=1;
        scanf("%d%d%d",&n,&s,&t);
        for(int i=0; i<s; i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            //因为路是双向的,保存时要从a到b保留一次,从b到a保留一次
            u[l]=a;
            v[l]=b;
            w[l++]=c;
            u[l]=b;
            v[l]=a;
            w[l++]=c;
        }
        for(int i=0; i<t; i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            u[l]=a;
            v[l]=b;
            w[l++]=-c;//虫洞用的时间是负的
        }
        //Bellman-ford算法
        memset(dis,inf,sizeof(dis));
        dis[1]=0;
        for(int k=1; k<=l-1; k++)
        {
            int check=0;
            for(int i=1; i<=2*s+t; i++)
            {
                if(dis[v[i]]>dis[u[i]]+w[i])
                {
                    dis[v[i]]=dis[u[i]]+w[i];
                    check=1;
                }
            }
            if(check==0)break;
        }
        int flag=0;
        for(int i=1; i<=2*s+t; i++)
            if(dis[v[i]]>dis[u[i]]+w[i])//如果已经计算好的最短路还能被更新,就说明存在负权回路
                flag=1;
        if(flag==1)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值