db2 各版本的系统要求

db2 专栏收录该内容
10 篇文章 0 订阅

DB2 服务器的安装需求(Windows)

要安装 DB2 UDB 服务器,必须满足下列操作系统、软件、硬件和通信需求:

操作系统需求

|有关最新的操作系统信息,请参阅 http://www.ibm.com/software/data/db2/udb/sysreqs.html

DB2 UDB 工作组服务器版在下列操作系统上运行:

  • 带有 Service Pack 6a 或更新版本的 Windows NT V4
  • |Windows 2000 Professional、Standard Server、Advanced Server 和 |Datacenter Server
  • |Windows XP(32 位和 64 位)
  • |Windows Server 2003(32 位和 64 位)

DB2 UDB 企业服务器版在下列操作系统上运行:

  • 带有 Service Pack 6a 或更新版本的 Windows NT V4
  • |Windows 2000 Professional、Standard Server、Advanced Server 和 |Datacenter Server。对于 Windows Terminal Server,Windows 2000 ServiceTerminal |Server 是必需的。
  • Windows Server 2003(32 位和 64 位)

在下列任何环境中运行 DB2 应用程序都需要 Windows 2000 Service Pack 3 和 Windows XP Service Pack 1:

  • 具有使用“开放式数据库连接”(ODBC)的 COM+ 对象的应用程序。
  • 将“OLE DB 提供程序”用于 ODBC 并且禁用了 OLE DB 资源池的应用程序

如果不能确定您的应用程序环境是否合格,则建议安装适当的 Windows 服务级别。

有关 COM+ 的更多信息,请参阅以下站点中的 Microsoft Knowledge Base 一文:

  • http://support.microsoft.com/default.aspx?scid=KB;EN-US;306414

对于 DB2 服务器或者作为 DB2 产品的一部分交付的任何应用程序,Windows 2000 Service Pack 3 和 Windows XP Service Pack 1 不是必需的。

硬件需求
对于 32 位 DB2 产品,需要有 Pentium 或与 Pentium 兼容的 CPU。对于 64 位的 DB2 产品,需要 Itanium 或与 Itanium 兼容的 CPU。

软件需求
  • MDAC 2.7 是必需的。如果尚未安装 MDAC 2.7,则“DB2 安装”向导将安装它。
  • |需要适当的 IBM SDK for Java 来使用基于 Java 的工具。请参阅 DB2 UDB |的 IBM Software Development Kit for Java 级别(Windows 和 UNIX)。
  • |必须启用 TCP/IP 支持才能查看联机帮助。
  • |支持下列浏览器:|
    • |Mozilla 1.0 或更高版本
    • |Internet Explorer V5.5 或 6.0(V6.0 用于 Windows XP)|

Windows 2000 Terminal Server 安装局限性

不能在 Windows 2000 Terminal Server edition 上使用远程会话从网络映射驱动器安装 DB2 版本 8。可用的变通方法是使用“通用命名约定”(UNC)路径来启动安装,或从控制台会话运行安装。

例如,如果 serverA 上的目录 c:\pathA\pathB\...\pathN 共享为 serverdir,则可以打开 \\serverA\serverdir\filename.ext 以访问服务器上的文件c:\pathA\pathB\...pathN\filename.ext

通信需求
可以使用 APPC、TCP/IP、MPTN(基于 TCP/IP 的 APPC)、命名管道和 NetBIOS。要远程管理版本 8 DB2 UDB 数据库,必须使用 TCP/IP 来进行连接。使用 DB2 Connect 服务器支持功能部件的 DB2 版本 8 服务器只支持出站客户机 APPC 请求;不支持任何入站客户机 APPC 请求。
  • 对于 TCP/IP、命名管道和 NetBIOS 连接,不需要任何附加软件。
  • 对于通过 DB2 Connect 服务器支持功能部件进行的 APPC(CPI-C)连接,需要下表中显示的其中一个通信产品。 

    表 1. 受支持的 SNA(APPC)产品

    操作系统SNA(APPC)通信产品
    Windows NT

    IBM Communications Server V6.1.1 或更新版本

    带有 CSD 3 的 IBM 个人通信 Windows 版版本 5.0

    Microsoft SNA Server V3 Service Pack 3 或更新版本 

    Windows 2000

    IBM Communications Server V6.1.1 或更新版本

    带有 CSD 3 的 IBM 个人通信 Windows 版版本 5.0

    Microsoft SNA Server V4 Service Pack 3 或更新版本 

    Windows XP

    带有 APAR IC23490 的 IBM 个人通信 Windows 版版本 5.5 

    Windows Server 2003不受支持。
  • 如果计划使用 LDAP(轻量级目录访问协议),则需要 Microsoft LDAP 客户机或 IBM SecureWay LDAP Client V3.2.1 或更新版本。

Windows(64 位)注意事项
  • 支持本地 32 位应用程序。
  • 支持 32 位 UDF 和存储过程。
  • 支持来自远程 32 位低级别客户机的 SQL 请求。

  • 对于 SQL 请求,DB2 版本 8 Windows 64 位服务器仅支持来自 DB2 版本 6 和版本 7 的 32 位客户机的连接。不支持来自版本 7 的 64 位客户机的连接

Installation requirements for DB2 servers (AIX)

This topic lists the hardware, operating system, software, and communications requirements for DB2 Enterprise Server Edition and DB2 Workgroup Server Edition on AIX.

Hardware requirements
One of:
  • IBM RISC/6000
  • eServer pSeries

Operating system requirements

|For the most up-to-date operating system information, see http://www.ibm.com/software/data/db2/udb/sysreqs.html.

DB2 Enterprise Server Edition, for either single-partition or partitioned database environment, and DB2 Workgroup Server Edition, on single-partition environments only, are available on:

AIX Version 5.1.0 (32-bit and 64-bit)
with Maintenance level 6

AIX Version 5.2.0 (32-bit and 64-bit)
with Maintenance level 3

For Java:
OpenGL.OpenGL_X.rte.base

OpenGL.OpenGL_X.rte.soft

X11.adt.lib

Note:
You can query your system to see if a particular APAR is installed with the  instfix -v -i -k <APAR> command. For example,  instfix -v -i -k IY31254.

The following AIX file sets are required to install or run DB2 in languages other than English:

  • X11.fnt.ucs.ttf (AIX Windows Unicode TrueType Fonts)
  • |xlC.rte |6.0.0.8
  • For Asian languages, the following file sets are also required:
    • X11.fnt.ucs.ttf_CN (for zh_CN or Zh_CN)
    • X11.fnt.ucs.ttf_KR (for ko_KR)
    • X11.fnt.ucs.ttf_TW (for zh_TW or Zh_TW)

AIX file sets can be downloaded from: http://techsupport.services.ibm.com/server/fixes

Software requirements
  • |You require the appropriate IBM SDK for Java to use Java-based |tools. See IBM Software Development Kit for Java levels for DB2 UDB |(Windows and UNIX).
  • |If you plan to use Kerberos Authentication, you require IBM Network |Authentication Service client v1.3 or later running on AIX V5.2 |or higher.
  • |The following browser is required to view online help: Mozilla |Version 1.0 or greater.

DB2 Administration Server (DAS) requirements
The following requirements must be met:
  • |A DAS must be created on each DB2 server that you wish to administer |for the GUI tools to work properly, only one DAS needs to reside on each|physical machine.
  • Each DAS must be created under a user ID (same as an instance).
  • If the same user ID is to be used on all physical computers, then that userID's home directory cannot be shared (cross mounted) with the other computers.
  • If a different user ID is used for each DAS, then the home directories of the user IDs that are used can be shared (cross mounted).
  • As long as a DAS is created on each computer, it does not matter whether:
    • A different user ID is used for each DAS, or
    • The same user ID is used and that the user ID's home directory is not shared.
|

| DB2 UDB installation on NFS (Network File System)
|The installation of DB2 products on NFS (Network File System) is not  |supported. Installing DB2 on NFS (for example, NFS mounting  |/usr/opt/db2_08_01 or /opt/IBM/db2/V8.1) can be error prone and these  |errors can be difficult to diagnose.

|Only the DB2 installation image can be NFS-mounted (located on a system |other than the one DB2 runs on, or a remote filesystem or partition). |DB2 must be installed to a local drive and not an NFS-mounted drive.

|For example, you can copy your DB2 product CD onto system A (for example, |an NFS server), and install DB2 on systems B, C, and D using NFS to launch the|DB2 installation code from system A. However, you cannot install your |DB2 product on system A, and then use DB2 on systems B, C, or D. |Additionally, you cannot launch the DB2 installation process on system B, |install the code on system A, and use it on system B. The DB2 code must |be local to the system running DB2.

Installation requirements for DB2 servers (Linux)

This topic lists the hardware, distribution, package, software, and communication requirements for DB2 Enterprise Server Edition, DB2 Workgroup Server Edition, and DB2 Workgroup Server Unlimited Edition on Linux.

Hardware requirements
DB2 Workgroup Server Edition and DB2 Workgroup Server Unlimited Edition are supported on:
  • |x86 (Intel Pentium, Intel Xeon, and AMD Athlon)
  • |x86-64 (Intel EM64T and AMD64)
  • |IA64 (Intel Itanium 2 or higher)
  • |POWER (any iSeries or pSeries that support Linux)

DB2 Enterprise Server Edition, in either a single-partition or partitioned environment, is supported on:

  • |x86 (Intel Pentium, Intel Xeon, and AMD Athlon)
  • |x86-64 (Intel EM64T and AMD64)
  • |IA64 (Intel Itanium 2 or higher)
  • |POWER (any iSeries or pSeries that support Linux)
  • |S/390 (9672 Generation 5 or later, Multiprise 3000) or eServer |zSeries.|
    • |The Database Partitioning Feature (DPF) is not supported.|

Distribution requirements
|For the latest information on supported Linux distributions, point  |your browser to  |http://www.ibm.com/db2/linux/validate.

|You may be required to update your kernel configuration |parameters. The kernel configuration parameters are set in |/etc/sysctl.conf. Refer to your operating system |manual for information on setting and activating these parameters using the |sysctl command.|

| Package requirements
|The following tables list the package requirements for SUSE LINUX and Red  |Hat distributions for DB2 partitioned servers (Linux) Version  |8.2. The pdksh package is required for all DB2 systems.  |The rsh-server and nfs-utils packages are required for partitioned database  |systems. Both packages should be installed and running to continue with  |the setup of DB2 on partition database systems. To have the rsh-server  |running, inetd (or xinetd) must be installed and running as well.

|For more information, see your Linux distribution documentation. 
|

Package requirements for SUSE LINUX
Package nameDescription
pdkshKorn Shell. This package is required for partitioned database environments.
rsh-serverThis package contains a set of server programs which allow users to run commands on remote computers, login in to other computers, and copy files between computers (rsh, rexec, rlogin, and rcp).
nfs-utilsNetwork File System support package. It allows access for local files to remote computers.

|
Package requirements for Red Hat
DirectoryPackage nameDescription
/System Environment/ShellpdkshKorn Shell. This package is required for partitioned database environments.
/System Environment/Daemonsrsh-serverThis package contains a set of programs which allow users to run commands on a remote computer. Required for partitioned database environments.
/System Environment/Daemonsnfs-utilsNetwork File System support package. It allows access for local files to remote computers.

Software requirements
  • |You require the appropriate IBM SDK for Java to use Java-based |tools. See IBM Software Development Kit for Java levels for DB2 UDB |(Windows and UNIX).
  • |The following browser is required to view online help: Mozilla |Version 1.0 or greater.
  • |X Window System software capable of rendering a graphical user |interface is required if you want to use the DB2 Setup wizard to install DB2|Enterprise Server Edition or if you want to use any DB2 graphical |tools.
  • |If you plan to use Kerberos Authentication, you require Red Hat |Enterprise Linux Advanced Server 3 (x86 only) with IBM Network Authentication |Service 1.4.
|

| Communication requirements
|TCP/IP is required to access remote databases. Your particular  |Linux distribution provides TCP/IP connectivity if it is selected during the  |installation. If your Linux computer is installed on an existing  |network and is required to use a static IP address, then information similar  |to that found in the following table should be collected from your network  |administrator: 
|
Example of TCP/IP settings
NameExample number
Host IP address192.168.0.3
Subnet mask255.255.255.0
Gateway192.168.0.1

|This information should be specified either during the installation of |your Linux distribution, or after the installation is finished using your|distribution's setup utility.

DB2 Administration Server (DAS) requirements
The following requirements must be met:
  • A DAS must be created on each physical system for the Control Center and the Task Center to work properly.
  • Each DAS must be created under a userID (same as an instance).
  • If the same userID is to be used on all physical systems, then that userID's home directory cannot be shared (cross mounted) with the other systems.
  • If a different userID is used for each DAS, then the home directories of the userIDs that are used can be shared (cross mounted).
  • As long as a DAS is created on each system, it does not matter whether:
    • A different userID is used for each DAS, or
    • The same userID is used and that the userID's home directory is not shared.
|

| Installing DB2 products or sharing instance directory on NFS (Network File |System)
|The installation of DB2 products on NFS (Network File System) is not  |supported. Installing DB2 on NFS (for example, NFS mounting  |/usr/opt/db2_08_01 or /opt/IBM/db2/V8.1) can be error prone and these  |errors can be difficult to diagnose.

|Only the DB2 installation image can be NFS-mounted (located on a system |other than the one DB2 runs on, or a remote filesystem or partition). |DB2 must be installed to a local drive and not an NFS-mounted drive.

|For example, you can copy your DB2 product CD onto system A (for example, |an NFS server), and install on systems B, C, and D using NFS to launch the DB2|installation code from system A. However, you cannot install your DB2 |product on system A, and then use DB2 on systems B, C, or D. |Additionally, you cannot launch the DB2 installation process on system B, |install the code on system A, and use it on system B. The DB2 code must |be local to the system running DB2.


  • 1
    点赞
  • 0
    评论
  • 0
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值