poj-1988 Cube Stacking-并查集

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4


Sample Output

1
0
2

代码:

#include<cstdio>
#define max_n 30000
using namespace std;

struct Cube
{
    int p;//记录父亲是谁
    int d;//记录与假根的距离
    int tot;//记录当前一共有多少个块
};

Cube cube[max_n];

void init(int n)//初始化
{
    int i;
    for(i=1;i<=n;++i)//没有第0个箱子
    {
        cube[i].p=i;
        cube[i].d=0;//每个人都是自己的父亲距离自己0
        cube[i].tot=1;
    }

}

int findp(int x)
{
    if(cube[x].p==x) return x;//返回假父亲的编号
    else
    {
        int t=cube[x].p;//存下x上面连得块
        cube[x].p = findp(cube[x].p);//把x链接到它上面那个块的父亲上
        cube[x].d += cube[t].d;//加上距离
        return cube[x].p;    ///这步不能漏!!!!  把x的父节点传回去
    }
}

void unite (int x,int y)//结合
{
    int xp,yp,t;
    xp=findp(x);//x的父亲p1
    yp=findp(y);//y的父亲p2
    if(xp==yp) return ;//在一串了就不并了!!
    cube[yp].p=xp;
    cube[yp].d=cube[xp].tot;
    cube[xp].tot+=cube[yp].tot;
}

int main()
{
    init(max_n);
    int p;
    scanf("%d",&p);
    getchar();
    while(p>0)
    {
        char op;
        scanf("%c",&op);
        if(op=='M')
        {
            int x,y;
            scanf("%d%d",&x,&y);
            unite(x,y);
        }
        else if(op=='C')
        {
            int x;
            scanf("%d",&x);
            int xp=findp(x);
            printf("%d\n",cube[xp].tot-cube[x].d-1);
        }
        getchar();
        p--;
    }
    return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值