POJ - 1988 Cube Stacking (并查集)

Cube Stacking

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

题目大意:有两种操作:M  x  y  把包含x的栈放到含y的栈上      C  x  查询含x栈中x下面有几个数

思路:并查集合并栈,用两个数组记录栈中所有元素个和在x上面的个数

x所在栈中所有元素个数 - 在x上面的个数 - x本身   就是x下面的元素个数

代码:
 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int N=100000+20;
int fa[N],d[N],c[N];  //c记录所有元素个数,d记录在它上面的元素个数
int find(int x)
{
    int fx=fa[x];
    if(fa[x]==x) return x;
    fx=find(fa[x]);
    d[x]+=d[fa[x]];
    return fa[x]=fx;
}
void join(int x,int y)
{
    int fx,fy;
    fx=find(x),fy=find(y);
    if(fx!=fy)
        fa[fy]=fx;
    d[fy]+=c[fx];  
    c[fx]+=c[fy];
}
int main()
{
    int n;
    while(~scanf("%d%d",&n))
    {
        char s;
        int x,y;
        for(int i=1;i<=n;i++){fa[i]=i;c[i]=1;d[i]=0;}
        for(int i=0;i<n;i++)
        {
            scanf(" %c",&s);
            if(s=='M')
            {
                scanf("%d%d",&x,&y);
                join(x,y);
            }
            else
            {
                scanf("%d",&x);
                y=find(x);
                printf("%d\n",c[y]-d[x]-1);
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值