poj 2531 Network Saboteur

 Network Saboteur

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).
Output file must contain a single integer -- the maximum traffic between the subnetworks.

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90


题目大意

给你一堆点集,任意两点间有个距离,你的任务是把点集分为两部分,在同一部分的点集之间没有距离,只有两个集合间的点有距离,问怎么分点能让距离和最大

解题思路

数据量也不是很大,用的是dfs,一开始把所有点放在一个点集,然后看这个点分到另一个点集会不会使距离和变大,用dfs枚举每个点,注意回溯

当这个点加入另一个集合时候,sum =sum + 这个点与原来集合的每个点的距离 - 这个点与新集合中每个点的距离


代码

#include <cstring>
#include <cstdio>
#include <iostream>
#include <vector>
#include <algorithm>
#include <string>
#include <queue>
#define INF 0x3f3f3f3f
using namespace std;

int a[25][25];
int used[25];
int n,mmax=0;
int f(int x)
{
    int sum=mmax;
    for(int i=1;i<=n;++i)
        if(!used[i]) sum+=a[x][i];
        else sum-=a[x][i];
    return sum;
}


void dfs(int x,int sum)
{
    if(x==n+1) return;
    used[x]=1;
    for(int i=1;i<=n;++i)
    {
        if(!used[i]) sum+=a[x][i];
        else sum-=a[x][i];
    }
    if(sum>mmax) mmax=sum;
    dfs(x+1,sum);
    //回溯
    for(int i=1;i<=n;++i)
    {
        if(!used[i]) sum-=a[x][i];
        else sum+=a[x][i];
    }
    used[x]=0;
    dfs(x+1,sum);
}

int main()
{
    int i,j;
    scanf("%d",&n);
    for(i=1;i<=n;++i)
        for(j=1;j<=n;++j)
            scanf("%d",&a[i][j]);
    dfs(1,0);
    printf("%d",mmax);
    return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值