浙江省赛E zoj 3962 Seven Segment Display

Seven Segment Display

Time Limit: 2 Seconds      Memory Limit: 65536 KB

A seven segment display, or seven segment indicator, is a form of electronic display device for displaying decimal numerals that is an alternative to the more complex dot matrix displays. Seven segment displays are widely used in digital clocks, electronic meters, basic calculators, and other electronic devices that display numerical information.

Edward, a student in Marjar University, is studying the course "Logic and Computer Design Fundamentals" this semester. He bought an eight-digit seven segment display component to make a hexadecimal counter for his course project.

In order to display a hexadecimal number, the seven segment display component needs to consume some electrical energy. The total energy cost for display a hexadecimal number on the component is the sum of the energy cost for displaying each digit of the number. Edward found the following table on the Internet, which describes the energy cost for display each kind of digit.

DigitEnergy Cost
(units/s)
06
12
25
35
44
55
66
73
DigitEnergy Cost
(units/s)
87
96
A6
B5
C4
D5
E5
F4

For example, in order to display the hexadecimal number "5A8BEF67" on the component for one second, 5 + 6 + 7 + 5 + 5 + 4 + 6 + 3 = 41 units of energy will be consumed.

Edward's hexadecimal counter works as follows:

  • The counter will only work for n seconds. After n seconds the counter will stop displaying.
  • At the beginning of the 1st second, the counter will begin to display a previously configured eight-digit hexadecimal number m.
  • At the end of the i-th second (1 ≤ i < n), the number displayed will be increased by 1. If the number displayed will be larger than the hexadecimal number "FFFFFFFF" after increasing, the counter will set the number to 0 and continue displaying.

Given n and m, Edward is interested in the total units of energy consumed by the seven segment display component. Can you help him by working out this problem?

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 105), indicating the number of test cases. For each test case:

The first and only line contains an integer n (1 ≤ n ≤ 109) and a capitalized eight-digit hexadecimal number m (00000000 ≤ m ≤ FFFFFFFF), their meanings are described above.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each test case output one line, indicating the total units of energy consumed by the eight-digit seven segment display component.

Sample Input
3
5 89ABCDEF
3 FFFFFFFF
7 00000000
Sample Output
208
124
327
Hint

For the first test case, the counter will display 5 hexadecimal numbers (89ABCDEF, 89ABCDF0, 89ABCDF1, 89ABCDF2, 89ABCDF3) in 5 seconds. The total units of energy cost is (7 + 6 + 6 + 5 + 4 + 5 + 5 + 4) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 6) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 2) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 5) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 5) = 208.

For the second test case, the counter will display 3 hexadecimal numbers (FFFFFFFF, 00000000, 00000001) in 3 seconds. The total units of energy cost is (4 + 4 + 4 + 4 + 4 + 4 + 4 + 4) + (6 + 6 + 6 + 6 + 6 + 6 + 6 + 6) + (6 + 6 + 6 + 6 + 6 + 6 + 6 + 2) = 124.


参考题解http://blog.csdn.net/black_miracle/article/details/70599035


题意 :

给你十六进制下  每个数字的价值  问从m开始  显示n个十六进制数字需要的价值  定义FFFFFFFF+1=0


解题思路

从 x ~ y的价值就是 (0~y) 价值  - ( 0~x-1)的价值

1)找到最高位,最高位前全为0 所以 + 6*(0的个数)

2)从最高位开始,每次固定最高位的值,其后面的位则随机选取 对应16^(i) 种情况

    /类比十进制 例如十进制 398 (8对应第0位)
    /分为 200~299 , 100 ~ 199 , 000 ~ 099 (3打头先不管)
    /i = 2,a[i] - 1 = j = 2时,
    /2出现了100(10^2)次,///对应下式 pow[i]*num[j]
    /后两位 每一位(共2位)都从 0~9 遍历了 10^1 轮 对应pow[i-1]*(i)*sum[15]
    /200~299 实际上是 00000200 ~ 00000299 前面的5个0 也出现了100(10^2)次
    /处理完成上述区间之后, 下标右移 此时 变成 000003XX ,也就是3在 i = 1 时候做的处理,
    /重复上述步骤,处理 80~89 70~79 …… 00~09

    /最低位单独处理 前面一位都固定位9了,相当于处理90~98,变化的只有0~8


代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;

ll num[20]={6,2,5,5,4,5,6,3,7,6,6,5,4,5,5,4},pow[10],sum[20];

void init(){

    pow[0]=1;

    for(ll i=1;i<=8;i++)///位权
        pow[i]=pow[i-1]*16;

    sum[0]=6;
    ///每一位都可能从0 ~ 15.
    ///sum【i】表示当前位从0 ~ i 共贡献多少
    for(int i=1;i<=15;i++)
        sum[i]=sum[i-1]+num[i];
}
///从0 ~ t一共贡献多少
ll solve(ll t){
    if(t==-1)return 0;
    if(t==0)return 48;
    ll a[10]={0,0,0,0,0,0,0,0,0,0};
    ll x=t,cnt=0;

    ///把 t 换成16进制
    while(x>=16){
        a[cnt++]=x%16;
        x/=16;
    }
    if(x>0)a[cnt]=x;

    ll i,j,ans=0,now=0;
    ///找到最高位,最高位前全为0 所以+6
    for(i=7;i>cnt;i--){
    	now+=6;
    }
    ///类比十进制 例如十进制398
    ///分为 200~299 , 100 ~ 199 , 000 ~ 099 (3打头先不管)
    ///i = 2,a[i] - 1 = j = 2时,
    ///2出现了100(10^2)次,///对应下式 pow[i]*num[j]
    ///后两位 每一位(共2位)都从 0~9 遍历了 10^1 轮 对应pow[i-1]*(i)*sum[15]
    ///200~299 实际上是 00000200 ~ 00000299 前面的5个0 也出现了100(10^2)次
    ///处理完成上述区间之后, 下标右移 此时 变成 000003XX ,也就是3在 i = 1 时候做的处理,
    ///重复上述步骤,处理 80~89 70~79 …… 00~09
    for(i=cnt;i>=1;i--){
    	for(j=a[i]-1;j>=0;j--){
	    	ans+=pow[i-1]*(i)*sum[15]+pow[i]*num[j];
	    	ans+=pow[i]*now;
	    }
	    now+=num[a[i]];
    }

    ///最低位单独处理 前面一位都固定位9了,相当于处理90~98,变化的只有0~8
    for(j=a[0];j>=0;j--)  ans += now+num[j];
    return ans;
}
int main(){
    int t;
    scanf("%d",&t);
    init();
    while(t--){
        ll n,m;
        scanf("%lld%llx",&n,&m);
        ll ans;
        if(m+n-1>4294967295LL)
            printf("%lld\n",solve(4294967295LL)-solve(m-1)+solve((m+n-1)%4294967296LL));
        else printf("%lld\n",solve(m+n-1)-solve(m-1));
    }
    return 0;
}




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值