HDU6092 Rikka with Subset-01背包dp-2017多校联盟5 第8题

Rikka with Subset

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has n positive A1An and their sum is m . Then for each subset S of A , Yuta calculates the sum of S .

Now, Yuta has got 2n numbers between [0,m] . For each i[0,m] , he counts the number of i s he got as Bi .

Yuta shows Rikka the array Bi and he wants Rikka to restore A1An .

It is too difficult for Rikka. Can you help her?  
 

Input
The first line contains a number t(1t70) , the number of the testcases.

For each testcase, the first line contains two numbers n,m(1n50,1m104) .

The second line contains m+1 numbers B0Bm(0Bi2n) .
 

Output
For each testcase, print a single line with n numbers A1An .

It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.
 

Sample Input
  
  
2 2 3 1 1 1 1 3 3 1 3 3 1
 

Sample Output
  
  
1 2 1 1 1
Hint
In the first sample, $A$ is $[1,2]$. $A$ has four subsets $[],[1],[2],[1,2]$ and the sums of each subset are $0,1,2,3$. So $B=[1,1,1,1]$
 

Source
 



/*
题意:
一个序列a有n个数,和为m,这个序列能组成2^n个子序列,bi表示这些子序列中和为i的个数
现在给你bi,i∈[0,m]求出序列a,a按字典序输出

解题思路
首先能明确的是b[0]一定等于1,并且b中第一个不为0的i一定有b[i]个。
b[i]=i的个数+组合成i的方案数.当确定a中存在i,并且能组合出j-i,那么一定能组合出j,
这种途径得到j的方案数就是j-i的方案数
*/

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

const int maxn = 1e4 + 10;

int dp[maxn];///组合成i的方案数,不包括i本身,(准确的说是在完成第46行循环之前不包括本身。)
int b[maxn];
int n,m;

int main()
{
    int t;

    scanf("%d", &t);
    while (t > 0)
    {
        t--;
        memset(dp,0,sizeof(dp));
        dp[0] = 1;
        scanf("%d%d",&n,&m);
        for(int i = 0;i<=m;++i){
            scanf("%d",&b[i]);
        }
        bool f = 0;
        for(int i = 1;i<=m;++i){
            int cnt = b[i]-dp[i];///b[i]=i的个数+组成i的方案数dp[i]
            if(cnt<=0) continue;///不存在i
            for(int k = 0;k<cnt;++k){///a里面肯定有cnt个i
                if(f) printf(" ");
                f=1;
                printf("%d",i);
                for(int j = m;j>=i;--j){
                    dp[j] += dp[j-i];///组成j-i的方案分别加上i就能组成j,加上这种途径获得的方案数
                    //dp[j+i] += dp[j];一样的也能过,注意j的范围
                }
            }
        }
        puts("");
    }
    return 0;
}

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值