hdu 6092 Rikka with Subset(dp背包)

Rikka with Subset

Problem Description 
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has n positive A1−An and their sum is m. Then for each subset S of A, Yuta calculates the sum of S.

Now, Yuta has got 2n numbers between [0,m]. For each i∈[0,m], he counts the number of is he got as Bi.

Yuta shows Rikka the array Bi and he wants Rikka to restore A1−An.

It is too difficult for Rikka. Can you help her?

Input 
The first line contains a number t(1≤t≤70), the number of the testcases.

For each testcase, the first line contains two numbers n,m(1≤n≤50,1≤m≤104).

The second line contains m+1 numbers B0−Bm(0≤Bi≤2n).

Output 
For each testcase, print a single line with n numbers A1−An.

It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.

Sample Input 

2 3 
1 1 1 1 
3 3 
1 3 3 1

Sample Output 
1 2 
1 1 1 

Hint

In the first sample,  A  is  [1,2] A  has four subsets  [],[1],[2],[1,2]  and the sums of each subset are  0,1,2,3 . So  B=[1,1,1,1]  

Source
2017 Multi-University Training Contest - Team 5



题意:
给你一个B[0...m],b[i]表示和为i的a中的子集的个数,再给你一个n表示a中元素的个数

解析:

这道题真的是做到吐血,想了一天的dp
就是用了类似背包的思想,和为k的子集个数可以用和为k-i(i从1...k-1遍历)的的子集个数加上i 这个元素来得到,
再从小到大遍历,这样b中每次最小的那个数就是该数在a中的个数,在将这些个值为i的数一个个拿出来,取删除b,使得删完后b变成去除i且满足原定义



#include<stdio.h>
#include<string.h>
const int MAXN = 1e4+10;

int b[MAXN];
int dp[MAXN];   //dp[i]表示和为i的子集个数
int c[MAXN],a[100];


int main()
{
	int t,n,m,cnt;
	scanf("%d",&t);
	while(t--)
	{
		cnt=0;
		scanf("%d%d",&n,&m);
		for(int i=0;i<=m;i++)
			scanf("%d",&b[i]);
		memset(dp,0,sizeof(dp));
		dp[0]=1;   //和为0的子集有1个——空集
		for(int i=1;i<=m;i++)   
		{
			c[i]=b[i]-dp[i];   //值为i的数在a中有c[i]个,除了i本身外的和为i的子集的和
			for(int j=0;j<c[i];j++)
			{
				a[cnt++]=i;
				for(int k=m;k>=i;k--)    //在a中每加一个i,和为k的子集就比原来多了和为k-i的子集个数
					dp[k]+=dp[k-i];     //因为原来的和为k-i的子集个数加上这个i就变成了和为k的集合

			}

		}
		for(int i=0;i<cnt;i++)
		{
			if(i==0) printf("%d",a[i]);
			else printf(" %d",a[i]);
		}
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全评估测试题大模型安全评估测试题关键词库生成内容测试题库应拒答测试题库非拒答测试题大模型安全
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值