hdu 6129 Just do it -规律

Just do it

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 1318    Accepted Submission(s): 767


Problem Description
There is a nonnegative integer sequence a1...n of length n . HazelFan wants to do a type of transformation called prefix-XOR, which means a1...n changes into b1...n , where bi equals to the XOR value of a1,...,ai . He will repeat it for m times, please tell him the final sequence.
 

Input
The first line contains a positive integer T(1T5) , denoting the number of test cases.
For each test case:
The first line contains two positive integers
n,m(1n2×105,1m109) .
The second line contains
n nonnegative integers a1...n(0ai2301) .
 

Output
For each test case:
A single line contains n nonnegative integers, denoting the final sequence.
 

Sample Input
  
  
2 1 1 1 3 3 1 2 3
 

Sample Output
  
  
1 1 3 1
 

Source




/*
题意:
第一次 bi = a1^a2^...^ai
第k次 bi = b1^b2^...^bi
求出第m次的b数列

解题思路
模拟一下过程发现 第k次的b[i] = 第k次的b[i-1] + 第k-1次的b[i]。
于是把前5次模拟出来,如图,可以发现a[i]的异或次数是杨辉三角,
当c(n,m)为奇数时候,该异或有效,判断c(n,m)有一个很巧妙地办法是(n&m)==m则是奇数
然后由于杨辉三角是从0层开始,每层第一个数也是从0开始,我们对应着找一下规律发现
第m次第j个元素系数是c(m+i-2,j-1) ,a b c d依次从第1、2、3、4位开始,详见代码
*/
#include <iostream>
#include <cstdio>
#include <stack>
#include <queue>
#include <algorithm>
#include <vector>
#include <cstring>
using namespace std;

const int maxn = 2e6+10;
int a[maxn],b[maxn];

int main()
{
    int t;
    scanf("%d",&t);
    while (t > 0){
        t--;
        int n,m;
        scanf("%d %d",&n,&m);
        memset(b,0,sizeof(b));
        for(int i = 1;i<=n;i++){
            scanf("%d",&a[i]);
        }
        for(int i = 1;i<=n;++i){///a,b,c,d....
            int x=m+i-2,y=i-1;
            if((x&y) == y){///系数是奇数
                for(int j=i;j<=n;++j){///第j位
                    b[j]^=a[j-i+1];
                }
            }
        }
        for(int i = 1;i<=n;++i) printf("%d%c",b[i],i==n?'\n':' ');


    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值