1004. Counting Leaves (30)
Input
Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.
Output
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.
Sample Input2 1 01 1 02Sample Output
0 1
/**
题意:
n个结点,m个非叶子节点
节点编号 k个孩子 孩子编号
求每层叶子节点个数
*/
#include<bits/stdc++.h>
using namespace std;
typedef pair<int,int> P;
const int maxn = 100+10;
const int INF = 0x3f3f3f3f;
vector <int> child[maxn];
int levelleaves[maxn];
void dfs(int node,int level){
if(child[node].size() == 0) {
levelleaves[level] ++;
return;
}
for(int i = 0;i<child[node].size();++i){
dfs(child[node][i],level+1);
}
}
int main(){
int n,m,id,k,t;
scanf("%d%d",&n,&m);
int leaves = n-m;
for(int i = 0;i<m;++i){
scanf("%d",&id);
scanf("%d",&k);
while(k--){
scanf("%d",&t);
child[id].push_back(t);
}
}
dfs(1,0);
printf("%d",levelleaves[0]);
int cnt = levelleaves[0];
for(int i = 1;cnt<leaves;++i){
printf(" %d",levelleaves[i]);
cnt += levelleaves[i];
}
return 0;
}