1004 Counting Leaves (30分)——C语言实现(dfs)

1004 Counting Leaves (30分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

题目大意:

给定结点数和非叶子结点数,求每层叶子结点个数,并输出。

思路:

二维数组a[i][j]存储:根结点为i时的j个子节点,从根结点开始遍历,直到遇到叶子结点,就将当前层数depth的book[depth]++;标记第depth层拥有的叶子结点数,最后输出。

代码:

#include<stdio.h>
int a[110][110];
int book[110], maxn = -1;
void dfs(int index, int depth){
	int count = 0;
	while(a[index][count] != 0){
		count++;
	}
	if(a[index][0] == 0){//叶子结点
 		book[depth]++;
		if(depth > maxn)
			maxn = depth;
		return;
	}
	for(int i = 0; i < count; i++){
		dfs(a[index][i], depth + 1);
	}
}
int main(){
	int n, m, i, j;
	scanf("%d %d", &n, &m);
	for(i = 0; i < m; i++){
		int node, k;
		scanf("%d %d", &node, &k);
		for(j = 0; j < k; j++){
			int t;
			scanf("%d", &t);
			a[node][j] = t;
		}
	}
	dfs(1, 0); 
	printf("%d", book[0]);
	for(i = 1; i <= maxn; i++)
		printf(" %d", book[i]);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值