PAT (Basic Level) Practice (中文)1044 火星数字 (20 分) map 映射
1. std::map
template < class Key, // map::key_type
class T, // map::mapped_type
class Compare = less<Key>, // map::key_compare
class Alloc = allocator<pair<const Key,T> > // map::allocator_type
> class map;
- 通俗的理解map:我们知道int型数组比如说 int a[100]是数组中的整型元素与数组指针下标的映射 char b[100]是数组中的字符元素与数组指针下标的映射,从上面我们看到元素映射到的指针都是一个数,但有时候我们想要映射到更多类型的数据的指针,以及将指针映射到更多类型的数据,这里用到了map。
- map的定义:
#include <map>
using namespace std;
map<typename1,typename2> mp;//typename是可以是基础数据类型如int char,也可以是结构体,还可以是STL的vector。
其中typename1是映射前的元素,typename2是映射后的元素(一前一后的映射顺序与位置相同),typename1被称作键,typename2称作值
2.PAT (Basic Level) Practice (中文)1044 火星数字 (20 分)解题
1044 火星数字 (20 分)
火星人是以 13 进制计数的:
地球人的 0 被火星人称为 tret。
地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。
输入格式:
输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。
输出格式:
对应输入的每一行,在一行中输出翻译后的另一种语言的数字。
输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115
13
#include <iostream>
#include <map>
#include <string>
using namespace std;
string unitDigit[13]={"tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec"};//个位
string tenDigit[13]={"tret","tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou"};
string numToStr[170]; //数字->火星文
map<string,int> strToNum;//火星文->数字
void init()
{
for(int i=1;i<13;i++)//对个位十位均不为0的数进行处理
{
for(int j=1;j<13;j++)
{
string str=tenDigit[i]+" "+unitDigit[j];//字符串拼接
numToStr[i*13+j]=str;
strToNum[str]=i*13+j;
}
}
for(int i=0;i<13;i++)//对个位为0-12,十位为0的数,与十位为0-12,个位为0的数进行处理
{
numToStr[i]=unitDigit[i];//个位赋值(十位为0的数)
strToNum[unitDigit[i]]=i;//将字符与数字映射
numToStr[i*13]=tenDigit[i];//十位赋值(个位为0的数)
strToNum[tenDigit[i]]=i*13;
}
}
int main()
{
init();//打表
int num;
scanf("%d%c",&num);
while(num--)
{
string str;
getline(cin,str);//查询的数
if(str[0]>='0'&&str[0]<='9')//如果是数字
{
int num=0;
for(int i=0;i<str.length();i++)
{
num=num*10+(str[i]-'0');
}
cout<<numToStr[num]<<endl;
}
else//如果是火星文
{
cout<<strToNum[str]<<endl;
}
}
return 0;
}