adb server version (32) doesn't match this client (41); killing...报错解决办法

在利用eclipse+python+SDK跑android自动化测试脚本时,遇到了该问题,看到一篇博客传送门,总结了该问题的几种情况。

我遇到的就是第一种情况,简单来讲就是电脑client的adb的版本与连接的手机server不能适配,无法执行。解决办法如下:

(1)去cmd执行“adb version”命令查看当前adb的版本是1.0.41;

(2)去网上下载1.0.32版本的adb.zip;

(3)解压缩后拿1.0.32版本的adb.exe替换\android-sdk-windows\platform-tools路径下的adb.exe即可。

其他的情况可去原文查看~

 

©️2020 CSDN 皮肤主题: 像素格子 设计师:CSDN官方博客 返回首页