Ignatius and the Princess IV ------[NWPU][2018寒假作业][通用版]一、热身 [Cloned]J题

“OK, you are not too bad, em… But you can never pass the next test.” feng5166 says.
“I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers.” feng5166 says.
“But what is the characteristic of the special integer?” Ignatius asks.
“The integer will appear at least (N+1)/2 times. If you can’t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha…..” feng5166 says.
Can you find the special integer for Ignatius?
Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
Output
For each test case, you have to output only one line which contains the special number you have found.
Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1
Sample Output
3
5
1

解题思路:
刚开始我怕输入的数过大,用int型变量会溢出,用数组标记会占用太大内存,所以选用了string存储数字,map负责记数。
但后来发现这样居然超时???
换成数组和int型居然就过了???
于是意识到了map的时间复杂度比数组大???
虽然还没搞清楚是为什么但就先记下了,后续学习二叉树可能就明白了???

#include<iostream>
#include<cstdio>
using namespace std; 

int N[100000];
//数组名为count就不行?
//用map会超时?用数组就不会? 

int main()
{
    int n;
    int num;
    int ans;
    while(cin>>n)
    {
        memset(N,0,sizeof(N));
        int temp=(n+1)/2;
        for(int i=1;i<=n;i++)
        {
            cin>>num;
            N[num]+=1;
            if(N[num]>=temp)
            {
                ans=num;
            }
        }
        cout<<ans<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值