Joseph------[NWPU][2018寒假作业][通用版]一、热身 [Cloned]R题

The Joseph’s problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, …, n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.
Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.
Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
Output
The output file will consist of separate lines containing m corresponding to k in the input file.
Sample Input
3
4
0
Sample Output
5
30

解题思路:
这虽然是一道水题,但还是做了很久。
最开始用非常原始的思路做,就是从1开始试,每试一次都要实现一遍游戏过程,用数组标记人的死活。因为要把已经死了的人跳过去,所以比较麻烦,而且每试一次都要把数组清零,即使打表也会超时。
后来参考了网上的思路,不用在意坏人的编号,只要确保前k个好人能活着。意思是,不用一直按2*k编号,如果坏人死了,直接让其他坏人补上去,总人数减少就可以了。这样不用考虑要跳过死人编号的问题,再结合打表就不会超时了。
第一个思路的代码:

#include<stdio.h>
#include<string.h>

int main()
{
    int k,i,peo[30],p,old,now,ori,loca,t,flag,joseph[14]={0};
    while(1)
    {
        scanf("%d",&k);
        if(k==0)
        {
            return 0;
        }
        if(joseph[k]!=0)
        {
            printf("%d\n",joseph[k]);
            continue;
        }
        ori=2*k;
        p=2*k;
        old=1;
        memset(peo,0,sizeof(peo));
        for(i=1;;i++)
        {
            while(1)
            {
                t=i%p;
                if(t==0) t=p;
                while(t)
                {
                loca=old%ori;
                if(loca==0) loca=ori;
                if(peo[loca]==0)
                {
                    t--;
                }
                old++;
                }
                now=loca;
                if(now>k)
                {
                old=now;
                peo[now]=1;
                p-=1;
                if(p==k)
                {
                    printf("%d\n",i);
                    joseph[k]=i;
                    flag=1;
                    break;
                }
                }
                else
                {
                memset(peo,0,sizeof(peo));
                p=2*k;
                old=1;
                flag=0;
                break;
                }
            } 
            if(flag==0)
            {
                continue;
            }
            else
            {
                break;
            }
        }
    }
} 

第二个思路的代码:

#include<stdio.h>

int main()
{
    int k,joseph[14]={0},i,p,old,now,flag;
    while(1)
    {
        scanf("%d",&k);
        if(k==0)
        {
            return 0;
        }
        if(joseph[k]!=0)
        {
            printf("%d\n",joseph[k]);
            continue;
        }
        p=2*k;
        old=1;
        for(i=1;;i++)
        {
             while(1)
             {
                now=(old+i-1)%p;
                if(now==0) now=p;
                if(now>k)
                {
                    old=now;//记录上一个死人的编号
                    p-=1;//人数减1
                    if(p==k)
                    {
                        joseph[k]=i;
                        printf("%d\n",i);
                        flag=1;
                        break;
                    }
                }
                else
                {
                    old=1;
                    p=2*k;
                    flag=0;
                    break;
                }
             }
             if(flag==1)
             {
                break;
             }
             else
             {
                continue;
             }
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值