//搞不清楚for循环真的害死人//贪心FatMouse's Trade------[NWPU][2018寒假作业][通用版]二E题

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
Sample Output
13.333
31.500

解题思路:
这道题思路跟前面做的两道贪心的题目想法类似。希望先交易j大f小的房间,所以计算j与f的比值,将其由大到小排序,从比值大的开始交易。

思路虽然简单,但是AC的道路却异常坎坷。
一开始WA的时候,我的第一反应是数据类型有问题,因为这道题有很多double型int型的数,又检查一遍之后发现还是WA。
然后我就觉得是sort的问题,事实证明我确实没有考虑求j和f比值时f为0的情况,但是改完之后还是WA。后来发现这个不用考虑,是我想多了。
于是找了网上AC的代码比对,发现最后应该用for循环而我用了while。我想了半天才明白,区别在于while循环只在m=0时退出,而for循环在m=0时和i>n时都会退出。就是说可能出现m还没用完但是所有房间都被买通了的情况。
我在while循环体最后面加了一个if(i>n) break;的语句后,还是WA,但是for循环的代码就AC了。想了半天这两个的区别,后来意识到for循环从一开始i=1时就执行条件表达式,而在我的while循环里面条件表达式是从i=2开始执行的。
也就是说,还存在n=0的测试数据!!!就是根本没有房间!!!
这谁想的到!!!我是陈独秀么???!!!
所以说,只有你想不到的,没有测不到的,还是不要给自己找不痛快,乖乖用for循环把。

#include<stdio.h>
#include<algorithm>
using namespace std;

double m;
int n;
struct node{
    double j;
    double f;
    double s;
}room[1010];

bool cmp(node x,node y)
{
    return x.s>y.s;
}

int main()
{
    while(1)
    {
        scanf("%lf%d",&m,&n);
        if(m==-1&&n==-1)
        {
            return 0;
        }
        for(int i=1;i<=n;i++)
        {
            scanf("%lf%lf",&room[i].j,&room[i].f);
            room[i].s=room[i].j/room[i].f;
        }
        sort(room+1,room+n+1,cmp);
        double ans=0; 
        for(int i=1;i<=n;i++)
        {
            if(m>=room[i].f)
            {
                m-=room[i].f;
                ans+=room[i].j;
            }
            else
            {
                ans+=m/room[i].f*room[i].j;
                break;
            }
        } 
        printf("%.3lf\n",ans);
    }
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值