//优先队列//结构体重载//Stones------二W

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0小于N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
Output
Just output one line for one test case, as described in the Description.
Sample Input
2
2
1 5
2 4
2
1 5
6 6
Sample Output
11
12

解题思路:
http://blog.csdn.net/c20182030/article/details/70757660
先学习了一下优先队列里怎么让结构体重载。
在结构体里重新定义小于号,优先队列会按照重载后的小于规则,从大到小排序。

friend bool operator < (node x,node y)
    {
        if(x.p!=y.p) return x.p>y.p;
        else return x.d>y.d;
    }

把这个优先队列当成一条路,然后模拟出走路的过程,把遇到的石子pop出去,如果是第奇数个石子,再把石子的新位置push到队列里,走到队列为空为止。
要注意的是如果一个位置有多个石子,所有石子都要处理,而不是只处理排在第一个的石子。

#include<stdio.h>
#include<queue>
using namespace std;

struct node
{
    int p;
    int d;
    friend bool operator < (node x,node y)
    {
        if(x.p!=y.p) return x.p>y.p;
        else return x.d>y.d;
    }
}stone[100000];

int main()
{
    int t,n,cnt,posi;
    node point,next;
    scanf("%d",&t);
    while(t--)
    {
        priority_queue<node> road;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&stone[i].p,&stone[i].d);
            road.push(stone[i]);
        }
        cnt=0;
        posi=0;
        while(road.empty()==false)
        {
            point=road.top();
            road.pop();
            cnt++;
            posi=point.p;
            if(cnt%2==1)
            {
                next.d=point.d;
                next.p=point.p+point.d;
                road.push(next);
            }
        }
        printf("%d\n",posi);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值