//动态规划入门题嘻嘻嘻//数字三角形------四A

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output
30

解题思路:
从三角形的顶点开始遍历,每一个点都可以选择加左上的数或右上的数,取最大值并记录。这样可以保证每一个点上的都是最大值。最后遍历底层找出底层的最大值。

#include<stdio.h>
#include<memory.h>
int dp[101][101];
int main()
{
    int n,t;
    scanf("%d",&n);
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=i;j++)
        {
            scanf("%d",&t);
            dp[i-1][j]>dp[i-1][j-1]?dp[i][j]=t+dp[i-1][j]:dp[i][j]=t+dp[i-1][j-1];
        }
    }
    int max=0;
    for(int i=1;i<=n;i++)
    {
        dp[n][i]>max?max=dp[n][i]:max=max;
    }
    printf("%d\n",max);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值