//用scanf和printf输入输出string//map的应用//Babelfish------三C

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input
Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output
Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as “eh”.
Sample Input
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay
atcay
ittenkay
oopslay
Sample Output
cat
eh
loops

解题思路:
这道题过程不难,主要就是数据量大需要用scanf和printf输入输出,因为有map所以需要用string类型。
一开始不知道怎么样scanf和printf输入输出string型所以一直有问题。
string类型中有一个.c_str()函数,能返回当前字符串的首地址。
printf(“%s”,s.c_str());就可以了
输入的话需要先用.resize预分配空间,然后再用scanf(“%s”,&s[0]);就可以了。
参考了这两篇博客
http://blog.csdn.net/spaceyqy/article/details/24840215
https://www.cnblogs.com/Annetree/p/6501559.html

#include<stdio.h>
#include<string>
#include<map>
using namespace std;

map<string,string> dic;

int main()
{
    string a,b;
    a.resize(15);
    b.resize(15);
    while(1)
    {
        scanf("%s",&a[0]);
        if(dic.count(a)==1)
        {
            break;
        }
        scanf("%s",&b[0]);
        dic[b]=a;
    }
    if(dic[a]!="")printf("%s\n",dic[a].c_str());
    else printf("eh\n");
    while(scanf("%s",&a[0])!=EOF)
    {
        if(dic[a]!="") printf("%s\n",dic[a].c_str());
        else printf("eh\n");
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值