//二分//WA后换成long long int试试也许就AC了//Drying------三E

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.
Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.
There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.
Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).
The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.
Input
The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).
Output
Output a single integer — the minimal possible number of minutes required to dry all clothes.
Sample Input
sample input #1
3
2 3 9
5
sample input #2
3
2 3 6
5
Sample Output
sample output #1
3
sample output #2
2

解题思路:
一开始实在没啥思路,也不知道怎么用二分,后来看到网上的题解才慢慢理解。
二分其实算是搜索的一种?大概就是通过不断缩小答案所在的范围来确定答案。也可以当做是一种另类的枚举?只不过是可以提前排除很多可能的更快速的枚举?
后来又想了想什么时候可以用上二分,大概需要两个条件吧,一个是需要枚举答案,一个是每次枚举的结果都包含能缩小答案范围的信息?

关于这道题,首先有两个需要注意的地方,一个是因为数很大,所以需要用long long int型,否则会WA。还有一个是要求大于等于(a[i]-mid)/(k-1)的最小整数,除了可以用ceil函数外,还可以(a[i]-mid+k-2)/(k-1)。

设某次二分出的一个值是mid:
1、对于一件ai值小于等于mid的衣服,直接晾干即可;
2、对于一件ai值大于mid值的衣服,最少的用时是用机器一段时间,晾干一段时间,设这两段时间分别是x1和x2,那么有mid=x1+x2,ai<=k*x1+x2,解得x1>=(ai-mid)/(k-1) ,所以对(ai-mid)/(k-1)向上取整就是该件衣服的最少用时。

#include<stdio.h>
long long int n,a[100010],k;

int ans(long long int mid)
{
    long long int time=0;
    for(int i=1;i<=n;i++)
    {
        if(a[i]>mid)
        {
            time+=(a[i]-mid+k-2)/(k-1);
        }
        else
        {
            continue;
        }
    }
    if(time>mid)
        return 1;
    else
        return 2;
}

int main()
{
    long long int i,max,left,right,mid,temp;
    while(scanf("%lld",&n)!=EOF)
    {
        max=0;
        for(i=1;i<=n;i++)
        {
            scanf("%lld",&a[i]);
            a[i]>max?max=a[i]:max=max;
        }
        scanf("%lld",&k);
        if(k==1)
        {
            printf("%lld\n",max);
            continue;
        }
        left=1;
        right=max;
        while(left<right-1)
        {
            mid=(left+right)/2;
            temp=ans(mid);
            if(temp==1)
            {
                left=mid;
            }
            else
            {
                right=mid;
            }
        }
        printf("%lld\n",right);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值