//dp动态规划入门题//最长公共子序列------四F

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0

解题思路:
其实就是画了一个表格,从一个字符和一个字符比较的情况一点一点往上推,跟背包问题想法一样,最重要的就是找到往上推的普遍规律。
比如当第m个字符和第n个字符比较时,如果第m个字符等于第n个字符,则m-1,n-1的答案加1就是m,n的答案,如果第m个字符不等于第n个字符,(m-1,n)和(m,n-1)中最大的就是(m,n)的答案。

#include<stdio.h>
#include<string.h>

int main()
{
    char s1[1000],s2[1000];
    int o[1000],n[1000];
    while(scanf("%s%s",s1,s2)!=EOF)
    {
        int l1=strlen(s1);
        int l2=strlen(s2);
        memset(o,0,sizeof(o));
        for(int i=0;i<l1;i++)
        {
            for(int j=0;j<l2;j++)
            {
                if(s2[j]==s1[i])
                    n[j+1]=o[j]+1;
                else
                    n[j+1]=n[j]>o[j+1]?n[j]:o[j+1];
            }
            for(int j=1;j<=l2;j++)
            {
                o[j]=n[j];
            }
        }
        printf("%d\n",n[l2]);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值