//深搜dfs//找到答案就一路return才不会超时//Square------三Y

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
Output
For each case, output a line containing “yes” if is is possible to form a square; otherwise output “no”.
Sample Input
3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5
Sample Output
yes
no
yes

解题思路:
这道题深搜的部分有点复杂,但是更麻烦的是会超时。
想要不超时主要有两个预防措施,一个是让明显不合格的数据(不能被4整除、最长的边大于边长)直接不进入深搜,这些必要条件要自己找,像“最长边大于边长”这个我一开始就没想到。另一个是深搜过程中只要找到一个答案就一路return出来,因为只要证明答案存在与否,不需要找出全部答案,关键是一直return这个操作太…emmmmm,所以我算是学习到了一个骚操作吧。

深搜的部分主要复杂在有三个形参,一个记录已经成功的边数,一个记录当前拼出来的边长,一个记录从哪个下标开始找。

#include<stdio.h>
#include<memory.h>
#include<algorithm>
using namespace std;

int sum,m,len[25],used[25],flag;

void dfs(int cnt,int edge,int start)
//已经拼出来的边数,边现在的长度,下标从哪里开始
{
    if(edge==sum)
    //边现在的长度等于边长,边数+1
    {
        cnt++;
        dfs(cnt,0,1);
        cnt--;
        if(flag==1) return;//flag=1直接return
    }
    if(cnt==4)
    //成功的边数等于4,flag=1
    {
        flag=1;
        return;
    }
    for(int i=start;i<=m;i++)
    {
        if(used[i]==0&&edge+len[i]<=sum)
        {
            used[i]=1;
            dfs(cnt,edge+len[i],i);
            used[i]=0;
            if(flag==1) return;//flag=1,直接return
        }
    }
}

int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int max=0;
        sum=0;
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%d",&len[i]);
            sum+=len[i];
            len[i]>max?max=len[i]:max=max;
        }
        if(sum%4!=0)
        //如果边的和不能被4整除,直接输出no
        {
            printf("no\n");
            continue;
        }
        else
        {
            sum/=4;
            if(max>sum)
            //如果最长的边大于边长,直接输出no
            {
                printf("no\n");
                continue;
            }
        }
        sort(len+1,len+m+1);
        memset(used,0,sizeof(used));
        flag=0;
        dfs(0,0,1);
        if(flag==1)
        {
            printf("yes\n");
        }
        else
        {
            printf("no\n");
        }
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值