hdu 1350 Taxi Cab Scheme(二分图最小路径覆盖)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1350

Problem Description
Running a taxi station is not all that simple. Apart from the obvious demand for a centralised coordination of the cabs in order to pick up the customers calling to get a cab as soon as possible, there is also a need to schedule all the taxi rides which have been booked in advance. Given a list of all booked taxi rides for the next day, you want to minimise the number of cabs needed to carry out all of the rides.

For the sake of simplicity, we model a city as a rectangular grid. An address in the city is denoted by two integers: the street and avenue number. The time needed to get from the address a, b to c, d by taxi is |a - c| + |b - d| minutes. A cab may carry out a booked ride if it is its first ride of the day, or if it can get to the source address of the new ride from its latest, at least one minute before the new ride’s scheduled departure. Note that some rides may end after midnight.
 

Input
On the first line of the input is a single positive integer N, telling the number of test scenarios to follow. Each scenario begins with a line containing an integer M, 0 < M < 500, being the number of booked taxi rides. The following M lines contain the rides. Each ride is described by a departure time on the format hh:mm (ranging from 00:00 to 23:59), two integers a b that are the coordinates of the source address and two integers c d that are the coordinates of the destination address. All coordinates are at least 0 and strictly smaller than 200. The booked rides in each scenario are sorted in order of increasing departure time.
 

Output
For each scenario, output one line containing the minimum number of cabs required to carry out all the booked taxi rides.
 

Sample Input
  
  
2 2 08:00 10 11 9 16 08:07 9 16 10 11 2 08:00 10 11 9 16 08:06 9 16 10 11
 

Sample Output
  
  
1 2
 

Source


题意是让更少的出租车去接顾客。。每辆车都有自己的出发时间,起点和终点。只要让第一辆车的终点到第二辆车的起点的总时间小于第二辆车的出发时间,就可以少派车了。

根据题意,建图,然后其实就是求最小路径覆盖。。

代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
const int maxn=505;
const int inf=1<<31-1;
struct node
{
    int a,b,c,d;
    int dis;
    int time;
}arr[maxn];
int distance(int a,int b,int c,int d)
{
    return abs(a-c)+abs(b-d);
}
int n;
int mp[maxn][maxn];
int vis[maxn];
int nx,ny;
int cx[maxn],cy[maxn];
int find(int u)
{
    for(int i=1;i<=ny;i++)
    {
        if(mp[u][i]&&!vis[i])
        {
            vis[i]=1;
            if(cy[i]==-1||find(cy[i]))
            {
                cy[i]=u;
                cx[u]=i;
                return 1;
            }
        }
    }
    return 0;
}
void match()
{
    int res=0;
    memset(cx,-1,sizeof(cx));
    memset(cy,-1,sizeof(cy));
    for(int i=1;i<=nx;i++)
    {
        if(cx[i]==-1)
        {
            memset(vis,0,sizeof(vis));
            res+=find(i);
        }
    }
   // printf("res=%d ",res);
    printf("%d\n",n-res);
}
int main()
{
    //freopen("in.txt","r",stdin);
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            int hh,mm,a,b,c,d;
            scanf("%d:%d %d %d %d %d",&hh,&mm,&a,&b,&c,&d);
            arr[i].time=hh*60+mm;
            arr[i].dis=abs(a-c)+abs(b-d);
            arr[i].a=a;
            arr[i].b=b;
            arr[i].c=c;
            arr[i].d=d;
        }
        nx=n;
        ny=n;
        memset(mp,0,sizeof(mp));
        for(int i=1;i<n;i++)
            for(int j=i+1;j<=n;j++)
              if(arr[i].time+arr[i].dis+distance(arr[i].c,arr[i].d,arr[j].a,arr[j].b)<arr[j].time)//第一辆车到第二辆车的时间小于第二辆车的出发时间
                 mp[i][j]=1;
//        for(int i=1;i<=n;i++)
//        {
//            for(int j=1;j<=n;j++)
//                printf("%d ",mp[i][j]);
//            printf("\n");
//        }
        match();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值