hdu 5050 Divided Land 大数求GCD 2014 ACM/ICPC Asia Regional Shanghai Online

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5050


Problem Description
It’s time to fight the local despots and redistribute the land. There is a rectangular piece of land granted from the government, whose length and width are both in binary form. As the mayor, you must segment the land into multiple squares of equal size for the villagers. What are required is there must be no any waste and each single segmented square land has as large area as possible. The width of the segmented square land is also binary.
 

Input
The first line of the input is T (1 ≤ T ≤ 100), which stands for the number of test cases you need to solve.

Each case contains two binary number represents the length L and the width W of given land. (0 < L, W ≤ 2 1000)
 

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then one number means the largest width of land that can be divided from input data. And it will be show in binary. Do not have any useless number or space.
 

Sample Input
  
  
3 10 100 100 110 10010 1100
 

Sample Output
  
  
Case #1: 10 Case #2: 10 Case #3: 110
 

Source
2014 ACM/ICPC Asia Regional Shanghai Online

题意:给你一个矩形,长和宽都是二进制表示,将矩形分为大小相等的正方形,求正方形的最大边长,二进制输出。
分析:因为要把长和宽都划分成最大,所以直接取它俩的最大公约数。

代码:
//package aa;
import java.util.*;
import java.math.*;
public class Main 
{
	public static void main(String[] args)
	{
		Scanner cin=new Scanner(System.in);
		int t;
		t = cin.nextInt();
		int i = 1;
		while(i <= t)
		{
			String a, b;
			a = cin.next();
			b = cin.next();
			BigInteger aa = solve(a);
			BigInteger bb = solve(b);
			BigInteger ans = aa.gcd(bb);
			System.out.print("Case #"+i+": ");
			fuc(ans);
			System.out.println();
			i++;
		}
	}
	public static BigInteger solve (String s)
	{
		BigInteger tmp = BigInteger.ONE;
		BigInteger sum = BigInteger.ZERO;
		int len = s.length();
		char ss[] = s.toCharArray();
		for(int i = len - 1; i >= 0; i--)
		{
			int tt = ss[i] - '0';
			sum = sum.add(tmp.multiply(BigInteger.valueOf(tt)));
			tmp = tmp.multiply(BigInteger.valueOf(2));
		}
		return sum;
	}
	public static void fuc(BigInteger n)
	{
		int arr[] = new int[2000];
		int cnt = 0;
		while(n.compareTo(BigInteger.valueOf(0)) > 0)
		{
			int dd = n.mod(BigInteger.valueOf(2)).intValue();
			arr[cnt] = dd;
			cnt++;
			n = n.divide(BigInteger.valueOf(2));
		}
		for(int i = cnt-1;i >= 0; i--)
			System.out.print(arr[i]);
	}
}

	


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值