Coincidence - 九度教程第 98 题

Coincidence - 九度教程第 98 题

题目

时间限制:1 秒 内存限制:32 兆 特殊判题:否
题目描述:
Find a longest common subsequence of two strings.
输入:
First and second line of each input case contain two strings of lowercase character a…z. There are no spaces before, inside or after the strings. Lengths of strings do not exceed 100.
输出:
For each case, output k – the length of a longest common subsequence in one line.
样例输入:
abcd
cxbydz
样例输出:
2
来源:
2008 年上海交通大学计算机研究生机试真题

该题即为最朴素的求解两字符串的最长公共子串长度。

#include <stdio.h>
#include <string.h>

int dp[101][101];

int max(int a,int b){
    return a>b ? a : b;
}

int main()
{
    char S1[101],S2[101];
    while(scanf("%s%s",S1,S2)!=EOF){
        int L1=strlen(S1);
        int L2=strlen(S2);//依次求得两个字符串

        for(int i=0;i<=L1;i++){
            dp[i][0]=0;
        }

        for(int j=0;j<=L2;j++){
            dp[0][j]=0;
        }

        for(int i=1;i<=L1;i++){
            for(int j=1;j<=L2;j++){
                //二重循环依次求得每个dp[i][j]值
                if(S1[i-1]!=S2[j-1]){
                    //因为字符串数组下标从0开始,
                    //所以第i个字符位置为S1[i-1],
                    //若当前两个字符不相等
                    dp[i][j]=max(dp[i][j-1],dp[i-1][j]);
                    //dp[i][j]为dp[i][j-1]和dp[i-1][j]中较大的一个
                }else{
                    dp[i][j]=dp[i-1][j-1]+1;
                    //若它们相等,则dp[i][j]比dp[i-1][j-1]再加1
                }
            }
        }
        printf("%d\n",dp[L1][L2]);//输出答案
    }
    return 0;
}

其时空复杂度都是 O(L1 * L2),其中 L1 和 L2 分别为两个字符串的长度。本节介绍了动态规划中又一个经典的问题——最长公共子序列问题,在牢记其算法原理的基础上还应着重考量算法分析的过程。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值