**
7-3 判断闰年及星期几 (20 分)
**
输入年月日的值(均为整型数),输出该年份是否为闰年,同时输出该日期为星期几。 其中:年份的合法取值范围为[1820,2020] ,月份合法取值范围为[1,12] ,日期合法取值范围为[1,31] ; 判断星期几的算法如下:假定公元0001年1月1日为星期一,因此只要计算出当前输入日期离0001年1月1日所差的天数,然后拿这个天数除以7求余数,当余数为0时,为星期日,当余数为1时,为星期一,以此类推,当余数为6时,为星期六。
要求:Main类中必须含有如下方法,签名如下:
public static void main(String[] args);//主方法;
public static boolean isLeapYear(int year) ;//判断year是否为闰年,返回boolean类型;
public static int numOfDays(int year,int month ,int day) ;//求出year-month-day到0001-1-1的距离天数,返回整型数;
public static String getWhatDay(int days) ; //根据天数返回星期几,其中参数days为天数,整型数,返回星期几的英文单词。
注意:不允许使用Java中和日期相关的类和方法。
解题报告
1.注意闰年的情况;
2.注意每个月的最大天数;
3.注意输入数据的有效范围。
输入格式:
在一行内输入年月日的值,均为整型数,可以用一到多个空格或回车分隔。
输出格式:
当输入数据非法及输入日期不存在时,输出“Wrong Format”;
当输入日期合法,以如下格式输出两行数据(注意,两行末尾均有个.)
第一行:年份(值) is a leap year.
第二行:年-月-日(均为变量值) is 星期几(输出为星期日到星期六的英文单词)
输入样例1:
2020 3 9
输出样例1:
2020 is a leap year.
2020-3-9 is Monday.
输入样例2:
1835 12 31
输出样例2:
1835 is not a leap year.
1835-12-31 is Thursday.
输入样例3:
1999 9 31
输出样例3:
Wrong Format
import java.util.Scanner;
class Main {
//主方法;
public static void main(String[] args) {
Scanner x = new Scanner(System.in);
int year=x.nextInt();
int month=x.nextInt();
int day=x.nextInt();
int days;
if(!checkInputValidity(year,month,day))
System.out.println("Wrong Format");
else{
isLeapYear(year);
if(isLeapYear(year))
System.out.println(year+" is a leap year.");
else
System.out.println(year+" is not a leap year.");
System.out.printf(year+"-"+month+"-"+day+" is ");
days=numOfDays(year,month,day);
getWhatDay(days);
}
}
//判断输入日期是否合法,返回布尔值
public static boolean checkInputValidity(int year,int month,int day) {
boolean checkInputValidity;
int[] a=new int[]{0,31,29,31,30,31,30,31,31,30,31,30,31};
if(!isLeapYear(year))
a[2] = 28;
checkInputValidity = (year>=1820&&year<=2020&&month>0&&month<=12&&day<=a[month]&&day>0);
return checkInputValidity;
}
//判断year是否为闰年,返回boolean类型
public static boolean isLeapYear(int year) {
boolean isLeapYear;
isLeapYear = (year % 4 == 0 && year % 100 !=0 )||year % 400 == 0;
return isLeapYear;
}
//求出year-month-day到0001-1-1的距离天数,返回整型数;
public static int numOfDays(int year, int month, int day) {
int ts=0,i;
int[] a=new int[]{0,31,29,31,30,31,30,31,31,30,31,30,31};
if(!isLeapYear(year))
a[2] = 28;
for(i=1;i<year;i++){
if(isLeapYear(i))//如果是闰年
ts=ts+366;
else//如果不是闰年
ts=ts+365;
}
if(month==1)
ts=ts+day;
else if(month==2)
ts=ts+day+a[1];
else if(month==3)
ts=ts+day+a[1]+a[2];
else if(month==4)
ts=ts+day+a[1]+a[2]+a[3];
else if(month==5)
ts=ts+day+a[1]+a[2]+a[3]+a[4];
else if(month==6)
ts=ts+day+a[1]+a[2]+a[3]+a[4]+a[5];
else if(month==7)
ts=ts+day+a[1]+a[2]+a[3]+a[4]+a[5]+a[6];
else if(month==8)
ts=ts+day+a[1]+a[2]+a[3]+a[4]+a[5]+a[6]+a[7];
else if(month==9)
ts=ts+day+a[1]+a[2]+a[3]+a[4]+a[5]+a[6]+a[7]+a[8];
else if(month==10)
ts=ts+day+a[1]+a[2]+a[3]+a[4]+a[5]+a[6]+a[7]+a[8]+a[9];
else if(month==11)
ts=ts+day+a[1]+a[2]+a[3]+a[4]+a[5]+a[6]+a[7]+a[8]+a[9]+a[10];
else if(month==12)
ts=ts+day+a[1]+a[2]+a[3]+a[4]+a[5]+a[6]+a[7]+a[8]+a[9]+a[10]+a[11];
return ts;
}
//根据天数返回星期几,其中参数days为天数,整型数,返回星期几的英文单词。
public static String getWhatDay(int days) {
int xq;
char a;
xq=days%7;
if(xq==1)
System.out.println("Monday.");
else if(xq==2)
System.out.println("Tuesday.");
else if(xq==3)
System.out.println("Wednesday.");
else if(xq==4)
System.out.println("Thursday.");
else if(xq==5)
System.out.println("Friday.");
else if(xq==6)
System.out.println("Saturday.");
else
System.out.println("Sunday.");
return null;
}
}