POJ - 1251 Jungle Roads(最小生成树算法:Kruskal和Prim算法)

题目链接https://vjudge.net/contest/351693#problem/E
在这里插入图片描述
Description
The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.
Input
The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.
Output
The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

翻译
给定一些边和点,求一个最小生成树。
输入:
先给定一个n,接下来n-1行,每一行第一个字母表示起点。接下来一个数k,表示从这个起点出发有几条边。后面对应k组字母+数字的组合,表示终点和这条路的花费

Kruskal算法:
1.边的权值从小到大排序
2.依次选边,若当前选取的边加入后使生成树T形成环,则舍弃当前边,否则标记当前变并计数
3.重复2的操作,直至生成树中包含n-1条边。否则当遍历完所有的边后,选取不到n-1条边,表示最小生成树不存在
产生环的判断
新加入的边的两个端点在并查集的同一个集合中,说明存在环
代码

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int N=1e2+10;
struct node
{
    int x,y,step;
} val[N];
int n,tot;
int f[N];
void init()
{
    for(int i=0; i<100; i++)
        f[i]=i;
}
int getf(int x)
{
    if(x!=f[x])
        f[x]=getf(f[x]);
    return f[x];
}
int gether(int x,int y)
{
    int t1=getf(x);
    int t2=getf(y);
    if(t1!=t2)
    {
        f[t1]=t2;
        return 1;
    }
    return 0;
}
int cmp(node t1,node t2)
{
    return t1.step<t2.step;
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        tot=0;
        n-=1;
        while(n--)
        {
            char ch,ch1;
            int sum,r;
            cin>>ch>>sum;
            for(int i=0; i<sum; i++)
            {
                cin>>ch1>>r;
                val[tot].x=ch-'A';
                val[tot].y=ch1-'A';
                val[tot].step=r;
                tot++;
            }
        }
        sort(val,val+tot,cmp);/*权值从小到大排序*/
        init();/*初始化祖先*/
        int vis=0,ans=0;
        for(int i=0; i<tot; i++)
        {
            if(gether(val[i].x,val[i].y))/*判断两个点是否在同一集合中*/
            {
                ans++;
                vis+=val[i].step;
            }
            if(ans==n)/*选取n-1条边*/
                break;
        }
        printf("%d\n",vis);
    }
    return 0;
}

Prim算法
思想
所有的顶点分成两个集合V1和V2。
V1中的点为已经选好连接入生成树的点,否则属于V2。
最开始。任选图中的一个点,其余的点属于V2,每次添加一个V2中的点到V1,该点是集合V2到集合V1中距离最小的一个点
所有的顶点属于V1,算法结束

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int N=1e2+10;
const int INF=0x3f3f3f3f;
int n,sum;
int dis[N],book[N],e[N][N];
void init()
{
    for(int i=0; i<N; i++)
        for(int j=0; j<N; j++)
        {
            if(i==j)
                e[i][j]=0;
            else
                e[i][j]=INF;
        }
    memset(book,0,sizeof(book));
}
void solve()
{
    int c=0;
    while(sum<n)
    {
        int mi=INF,u;
        for(int i=1;i<=n;i++)/*选取V2中的点距离V1最近*/
        {
            if(book[i]==0&&dis[i]<mi)
            {
                mi=dis[i];
                u=i;
            }
        }
        book[u]=1;
        sum++;
        c+=dis[u];
        for(int k=1;k<=n;k++)
        {
            if(book[k]==0&&dis[k]>e[u][k])
                dis[k]=e[u][k];/*更新生成树到非生成树的距离*/
        }
    }
    printf("%d\n",c);
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        init();/*初始化必不可少*/
        sum=0;
        int m=n-1;
        while(m--)
        {
            char ch,ch1;
            int sum,r;
            cin>>ch>>sum;
            for(int i=0; i<sum; i++)
            {
                cin>>ch1>>r;
                int t1=ch-'A'+1;
                int t2=ch1-'A'+1;
                e[t1][t2]=r;
                e[t2][t1]=r;
            }
        }
        book[1]=1;/*book[i]=1,表示i点加入V1中*/
        for(int i=1; i<=n; i++)
            dis[i]=e[1][i];
        sum++;/*记录V1中的点数*/
        solve();
    }
    return 0;
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zaiyang遇见

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值