顺序表的建立及遍历

读入n值及n个整数,建立顺序表并遍历输出。
输入格式:
读入n及n个整数
输出格式:
输出n个整数,以空格分隔(最后一个数的后面没有空格)。

输入样例:

4
-3 10 20 78

输出样例:

-3 10 20 78

代码

#include <stdio.h>
#include <stdlib.h>
#include<algorithm>
using namespace std;
#define MAXSIZE 100
typedef int ElemType;/*宏定义int型*/
typedef struct
{
    ElemType *elem;
    int length;
} SqList;
int n;
void InitList(SqList &L,int n)
{
    L.elem=(ElemType*)malloc(sizeof(MAXSIZE));/*开辟空间:(数据类型*)malloc(长度)*/
    L.length=0;
    ElemType q;
    for(int i=0; i<n; i++)
    {
        scanf("%d",&q);
        L.elem[L.length++]=q;
    }
    for(int i=0; i<L.length; i++)
        printf("%d%c",L.elem[i],i==L.length-1?'\n':' ');
    return;
}
int main()
{
    scanf("%d",&n);
    SqList L;
    InitList(L,n);
    return 0;
}
#include <stdio.h>
#include <stdlib.h>
#include <stdlib.h>
#include <malloc.h>
#include<algorithm>
using namespace std;
#define MAXSIZE 100
typedef int ElemType;/*宏定义int型*/
typedef struct
{
    ElemType elem[MAXSIZE];
    int last;
} SqList,*List;
int n;
void InitList(List &L,int n)
{
    L=(SqList*)malloc(sizeof(SqList));
    L->last=n-1;
    for(int i=0; i<=L->last; i++)
    {
        scanf("%d",&L->elem[i]);
    }
    for(int i=0; i<=L->last; i++)
        printf("%d%c",L->elem[i],i==L->last?'\n':' ');
}
int main()
{
    scanf("%d",&n);
    List L;/*List为结构体指针*/
    InitList(L,n);
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zaiyang遇见

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值