POJ 3255 Roadblocks(两次求最短路进而得到次短路)

题目描述https://vjudge.net/contest/374535#problem/C
Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1…N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).
Input
Line 1: Two space-separated integers: N and R
Lines 2…R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output
Line 1: The length of the second shortest path between node 1 and node N
Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450

Hint
Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

翻译
输入n和m,n个结点,m条无向边。求一条从1到n的次短路

分析
次短路是建立在最短路的基础上的
例如:
在这里插入图片描述
从1到4的最短路为 1 − > 2 − > 4 1->2->4 1>2>4,次短路为 1 − > 2 − > 3 − > 4 1->2->3->4 1>2>3>4

思路
邻接表存图
以1为起点,求一条从 1 − > n 1->n 1>n的最短路,将最短路的信息保存在 d i s 1 [ ] dis1[] dis1[]中。
以n为起点,求一条从 n − > 1 n->1 n>1的最短路,将最短路的信息保存在 d i s 2 [ ] dis2[] dis2[]中。

从1开始枚举,找大于最短路并且最小的路径

    int mi=inf;
    for(int i=1; i<=n; i++)
    {
        for(int j=fir[i]; j!=-1; j=nex[j])
        {
            int sum=dis1[i]+dis2[Node[j].v]+Node[j].w;
            if(sum>dis1[n]&&mi>sum)
                mi=sum;
        }
    }

完整代码:

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int N=5*1e3+10;
const int M=2*1e5+10;
const int inf=0x3f3f3f3f;
struct node
{
    int u;
    int v;
    int w;
} Node[M];
int fir[N];
int nex[M],tot;
int dis1[N],dis2[N];
bool book[N];
int n,m;
void AdjList(int x,int y,int z)
{
    Node[tot].u=x,Node[tot].v=y,Node[tot].w=z;
    nex[tot]=fir[x];
    fir[x]=tot;
    tot++;
}
void SPFA(int x,int *dis)
{
    memset(book,false,sizeof(book));
    queue<int>Q;
    Q.push(x);
    dis[x]=0;
    book[x]=true;
    while(!Q.empty())
    {
        int u=Q.front();
        Q.pop();
        book[u]=false;
        for(int i=fir[u]; i!=-1; i=nex[i])
        {
            if(dis[Node[i].v]>dis[u]+Node[i].w)
            {
                dis[Node[i].v]=dis[u]+Node[i].w;
                if(!book[Node[i].v])
                {
                    book[Node[i].v]=true;
                    Q.push(Node[i].v);
                }
            }
        }
    }
}
void init()
{
    tot=0;
    memset(dis1,inf,sizeof(dis1));
    memset(dis2,inf,sizeof(dis2));
    memset(fir,-1,sizeof(fir));
}
int main()
{
    init();
    scanf("%d%d",&n,&m);
    while(m--)
    {
        int x,y,z;
        scanf("%d%d%d",&x,&y,&z);
        AdjList(x,y,z);
        AdjList(y,x,z);
    }
    SPFA(1,dis1);///分别以起点和终点找两条最短路
    SPFA(n,dis2);
    int mi=inf;
    for(int i=1; i<=n; i++)
    {
        for(int j=fir[i]; j!=-1; j=nex[j])
        {
            int sum=dis1[i]+dis2[Node[j].v]+Node[j].w;
            if(sum>dis1[n]&&mi>sum)
                mi=sum;
        }
    }
    printf("%d\n",mi);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zaiyang遇见

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值