Sliding Window(单调队列)

题目

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1 3 -1] -3 5 3 6 7 -1 3
1 [3 -1 -3] 5 3 6 7 -3 3
1 3 [-1 -3 5] 3 6 7 -3 5
1 3 -1 [-3 5 3] 6 7 -3 5
1 3 -1 -3 [5 3 6] 7 3 6
1 3 -1 -3 5 [3 6 7] 3 7
Your task is to determine the maximum and minimum values in the sliding window at each position.

Input
The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.
Output
There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.
Sample Input
8 3
1 3 -1 -3 5 3 6 7
Sample Output
-1 -3 -3 -3 3 3
3 3 5 5 6 7

解题思路

利用两个单调队列,单调递增和单调递减,首先弄明白队尾和队首,然后当队尾比下一个值大(小)的时候移除队尾,维护队列的单调性;当队首位置加上k值小于当前i所在位置时,移除队首。
单调递减队列

错误分析

应用scanf和printf输出

#include<iostream>
#include<deque>
#include<stdio.h>
using namespace std;

int a[1010100],maxa[1010100],mina[1010100];
int main()
{
	deque<int >que1,que2;
	int n,k;
	scanf("%d%d",&n,&k);
	//cin>>n>>k;
	for(int i=1; i<=n; i++) scanf("%d",&a[i]);
	que1.push_front(1);
	que2.push_front(1);
	maxa[1]=1;
	mina[1]=1;
	k--;
	for(int i=2; i<=n; i++)
	{
		while(que1.size()&&que1.front()+k<i) que1.pop_front();
		while(que1.size()&&a[que1.back()]>=a[i]) que1.pop_back();
		que1.push_back(i);
		mina[i]=que1.front();
		while(que2.size()&&que2.front()+k<i) que2.pop_front();
		while(que2.size()&&a[que2.back()]<=a[i]) que2.pop_back();
		que2.push_back(i);
		maxa[i]=que2.front();
	}
	for(int i=k+1; i<=n; i++)
//		cout<<a[mina[i]]<<" ";
		printf("%d ",a[mina[i]]);
//	cout<<endl;
	printf("\n");
	for(int i=k+1; i<=n; i++)
//		cout<<a[maxa[i]]<<" "; 
		printf("%d ",a[maxa[i]]);
} 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值