POJ 2823 Sliding Window【单调队列】

Description

An array of size n ≤ 10 6 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

单调队列2

code:

View Code
#include<stdio.h>
#include<string.h>
int n,m;
int a[1000001];
int q[1000001];
void min_q()
{
int p=0,h=1,k;
q[1]=1;
for(k=1;k<=n;k++)
{
if(k-q[h]==m)
h++;
if(p==h-1||a[k]>a[q[p]])
{
p++;
q[p]=k;
}
else
{
while(p>=h&&a[k]<=a[q[p]])
{
q[p]=k;
p--;
}
p++;
}
if(k>=m)
printf("%d ",a[q[h]]);
}
putchar('\n');
}
void max_q()
{
int p=0,h=1,k;
q[1]=1;
for(k=1;k<=n;k++)
{
if(k-q[h]==m)
h++;
if(p==h-1||a[k]<a[q[p]])
{
p++;
q[p]=k;
}
else
{
while(p>=h&&a[k]>=a[q[p]])
{
q[p]=k;
p--;
}
p++;
}
if(k>=m)
printf("%d ",a[q[h]]);
}
putchar('\n');
}
int main()
{
int i;
scanf("%d%d",&n,&m);
memset(a,0,sizeof(a));
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
min_q();
max_q();
return 0;
}

 

转载于:https://www.cnblogs.com/dream-wind/archive/2012/03/14/2396294.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值