nim 博弈个人理解及POJ 2975 Nim 题解

目录

尼姆博弈的个人理解

1,奇异局势

2,异或运算

3,如何将非奇异局势转变为奇异局势

题解

题目

题意分析

解题思路

ac代码


尼姆博弈的个人理解

有若干堆各若干个物品,两个人轮流从某一堆取任意多的物品,规定每次至少取一个,多者不限,最后取光者得胜。

这里为了方便理解我们假设共有三堆各若干个作品

1,奇异局势

首先我们先了解一个名词:奇异局势

(a,b,c)分别表示三堆物品的数量,我们称之为局势;

奇异局势:某个玩家面对一个局势形成自己必输的场面。

这时我们可以知道:

(0,0,0)是奇异局势,无论谁面对这种局势都将是必输的状态

(0,n,n)是奇异局势,只要对手拿走和你一样多的物品最后都会导致(0,0,0)

实际上(1,2,3)也是奇异局势,无论对手先拿走多少,最后都会导致(0,n,n)类似的奇异局势。

2,异或运算

在二进制里有一种运算叫做异或运算,用符号xor表示。(因为xor不便于书写,我们下面用 ^ 来代替)

1(xor)1 = 0

0(xor)1 = 1

0(xor)0 = 0

总结来说即是相同为零,不同为一。

1 = 二进制(0 1)

2 = 二进制(1 0)

3 = 二进制(1 1)

                                ^

-----------------------------

0 = 二进制(0 0)

对于所有的奇异局势(a,b,c)都有a ^ b ^ c = 0

不能理解的话写个程序自己试试^v^

3,如何将非奇异局势转变为奇异局势

假如在我们面前的是一个(a,b,c)非奇异局势(假设a > b > c),我们该如何将他变为奇异局势?

因为奇异局势都满足a ^ b ^ c = 0

那么非奇异局势要想变为奇异局势也得满足a ^ b ^ c = 0

我们知道,异或运算,相同为零,所以a ^ b ^ c = 0 <=> a ^ b ^ (a ^ b) = 0

所以面对非奇异局势,我们只需要从 c 中减去 c - ( a ^ b)


题解

题目

Nim

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 8569Accepted: 4042

Description

Nim is a 2-player game featuring several piles of stones. Players alternate turns, and on his/her turn, a player’s move consists of removing one or more stones from any single pile. Play ends when all the stones have been removed, at which point the last player to have moved is declared the winner. Given a position in Nim, your task is to determine how many winning moves there are in that position.

A position in Nim is called “losing” if the first player to move from that position would lose if both sides played perfectly. A “winning move,” then, is a move that leaves the game in a losing position. There is a famous theorem that classifies all losing positions. Suppose a Nim position contains n piles having k1, k2, …, kn stones respectively; in such a position, there are k1 + k2 + … + kn possible moves. We write each ki in binary (base 2). Then, the Nim position is losing if and only if, among all the ki’s, there are an even number of 1’s in each digit position. In other words, the Nim position is losing if and only if the xor of the ki’s is 0.

Consider the position with three piles given by k1 = 7, k2 = 11, and k3 = 13. In binary, these values are as follows:

 111
1011
1101
 

There are an odd number of 1’s among the rightmost digits, so this position is not losing. However, suppose k3 were changed to be 12. Then, there would be exactly two 1’s in each digit position, and thus, the Nim position would become losing. Since a winning move is any move that leaves the game in a losing position, it follows that removing one stone from the third pile is a winning move when k1 = 7, k2 = 11, and k3 = 13. In fact, there are exactly three winning moves from this position: namely removing one stone from any of the three piles.

Input

The input test file will contain multiple test cases, each of which begins with a line indicating the number of piles, 1 ≤ n ≤ 1000. On the next line, there are n positive integers, 1 ≤ ki ≤ 1, 000, 000, 000, indicating the number of stones in each pile. The end-of-file is marked by a test case with n = 0 and should not be processed.

Output

For each test case, write a single line with an integer indicating the number of winning moves from the given Nim position.

Sample Input

3
7 11 13
2
1000000000 1000000000
0

Sample Output

3
0

题意分析

问如果先手要赢,能有多少中移动的方式。

解题思路

根据上面我们所说的,要把一个非奇异局势转变为奇异局势,可以用c - c ^ ( a ^ b ^ c )来判断是否大于零。 

因为( a ^ b ^ c ) ^ c = ( a ^ b ),如果大于零,那么就可以取走 c -( a ^ b )来达到奇异局势

ac代码

#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;

int main()
{
	int n;
	int a[1010];
	int ans,cnt;
	while(cin>>n&&n)
	{
		ans=cnt=0;
		for(int i=0; i<n; i++)
		{
			cin>>a[i];
			ans^=a[i];
		}
		if(ans==0) cout<<"0"<<endl;
		else
		{
			for(int i=0; i<n; i++)
			{
				int k=ans^a[i];
				if(k<a[i]) cnt++;
			}
			cout<<cnt<<endl;
		}
		
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值