08-图8 How Long Does It Take (25分)

Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers NN (\le 100100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N-1N1), and MM, the number of activities. Then MM lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i]E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i] the lasting time of the activity. The numbers in a line are separated by a space.

Output Specification:

For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output "Impossible".

Sample Input 1:

9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4

Sample Output 1:

18

Sample Input 2:

4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5

Sample Output 2:

Impossible

拓扑排序,好好背模板吧


#include<stdio.h>
#include<queue>
#include<vector>
using namespace std;
int maptime[100][100]={0};//c1-c2的时间 
int indegree[100]={0};
int timesum[100]={0};
int main(){
	int n,m,i,j,c1,c2,time;
	scanf("%d %d",&n,&m);
	vector<int>adj[n];
	for(i=0;i<m;i++){
		scanf("%d %d %d",&c1,&c2,&time);
		indegree[c2]++;
		adj[c1].push_back(c2);
		maptime[c1][c2]=time;
	}
	queue<int>q;
	for(i=0;i<n;i++){
		if(indegree[i]==0){
			q.push(i);
		}
	}
	int cou=0;
	while(!q.empty()){
		cou++;
		int head=q.front();
		q.pop();
		for(i=0;i<adj[head].size();i++){
			int next=adj[head][i];
			if(timesum[next]<timesum[head]+maptime[head][next]){//每个节点一定是最大值 
				timesum[next]=timesum[head]+maptime[head][next];
			}
			if(--indegree[next]==0){
				q.push(next);
			}
		}
	}
	if(cou!=n){
		printf("Impossible\n");
	}
	else{
		int max=-1;
		for(i=0;i<n;i++){
			if(timesum[i]>max){
				max=timesum[i];
			}
		}
		printf("%d",max);
	}
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值