08-图8 How Long Does It Take   (25分)

Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers NN (100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i], E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i] the lasting time of the activity. The numbers in a line are separated by a space.

Output Specification:

For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output "Impossible".

Sample Input 1:

9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4

Sample Output 1:

18

Sample Input 2:

4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5

Sample Output 2:

Impossible


解析:拓扑排序,增加一个数组EarliestTime来记录每个活动的最早完成时间


EarliestTime[j] = EarliestTime[V] + A[V][j];  把V = 0, j = 1代入到上图,再多试几个值,就能较好的理解这句话

#include <cstdio>
#include <cstdlib>
#include <queue>
using namespace std;
#define MAX 10000
#define INFINITY 65535
int N, M, A[MAX][MAX], ECT;  //ETC--earliest completion time
int getMax( int arr[] ) {
	int max = 0;
	for(int i = 0; i < N; i++)
		if( max < arr[i] )
			max = arr[i];
	return max;
}
int TopSort(){
	int V, cnt = 0, Indegree[MAX] = {0}, EarliestTime[MAX] = {0};
	queue<int> q;
	//计算各结点的入度
	for( int i = 0; i < N; i++ )
		for( int j = 0; j < N; j++ )
			if( A[i][j] != INFINITY )
				Indegree[j]++;	//对于有向边<i,j>累计终点j的入度
	//入度为0的入队
	for( int i = 0; i < N; i++ )
		if( Indegree[i] == 0 )
			q.push(i);
	while( !q.empty() ) {
		V = q.front();
		q.pop();
		cnt++;
		for( int j = 0; j < N; j++ )
			if( A[V][j] != INFINITY ) {  //<V, j>有有向边
				if( EarliestTime[V] + A[V][j] > EarliestTime[j] ){ //如果 V的最早完成时间 + j所需时间 > j的最早完成时间
					EarliestTime[j] = EarliestTime[V] + A[V][j];
				}
				if( --Indegree[j] == 0 )  //去掉V后,如果j的入度为0
					q.push(j);
			}
	}
	ECT = getMax(EarliestTime); //最早完成时间应是所有元素中最大的
	if( cnt != N ) return 0;	//如果没有取出所有元素,说明图中有回路
	else return 1;
}
int main(){
	int a, b;
	scanf("%d %d", &N, &M);
	//初始化图的边
	for( int i = 0; i < N; i++ )
		for( int j = 0; j < N; j++ )
			A[i][j] = INFINITY;
	//read
	for( int i = 0; i < M; i++ ) {
		scanf("%d %d", &a, &b);
		scanf("%d", &A[a][b]);
	}
	if( !TopSort() )
		printf("Impossible\n");
	else
		printf("%d\n", ECT);
	system("pause");
	return 0;
}


  • 6
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值