1119. Pre- and Post-order Traversals (30)


时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Special
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line "Yes" if the tree is unique, or "No" if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:
7
1 2 3 4 6 7 5
2 6 7 4 5 3 1
Sample Output 1:
Yes
2 1 6 4 7 3 5
Sample Input 2:
4
1 2 3 4
2 4 3 1
Sample Output 2:
No
2 1 3 4

给出前序和后序,问中序是否唯一。唯一则输出,不唯一输出可能的中序


参考算法笔记:

如果前序的第二个点和后序的倒数第二点相同,则根节点只有左孩子或右孩子。树就不唯一。


注意:

1.当s1==e1时,也就是一个结点的时候,直接返回。

2.最后居然还有一个换行。。。


#include<stdio.h>
#include<stdlib.h>
typedef struct Node *node;
struct Node{
	int x;
	node left;
	node right;
};
int pre[35],post[35];
int flag=1,printflag=1;
node build(int s1,int e1,int s2,int e2){
	node T=(node)malloc(sizeof(struct Node));
	T->x=pre[s1];
	T->left=T->right=NULL;
	if(s1==e1){//!!!
		return T;
	}
	int index,i;
	for(i=s2;i<=e2-1;i++){
		if(pre[s1+1]==post[i]){
			index=i;break;
		}
	}
	if(index==e2-1){//只有一个孩子结点 ,挂在左边右边都可以 
		flag=0;
		T->left=build(s1+1,e1,s2,e2-1);
	}
	else{
		T->left=build(s1+1,index-s2+s1+1,s2,index);
		T->right=build(index-s2+s1+2,e1,index+1,e2-1);
	}	
	return T;
}
void inorder(node T){
	if(T){
		inorder(T->left);
		if(printflag==1){
			printf("%d",T->x);printflag=0;
		}
		else{
			printf(" %d",T->x);
		}
		inorder(T->right);
	}
} 
int main(){
	int n,i;
	scanf("%d",&n);
	for(i=0;i<n;i++){
		scanf("%d",&pre[i]);
	}
	for(i=0;i<n;i++){
		scanf("%d",&post[i]);
	}
	node T=build(0,n-1,0,n-1);
	if(flag==1){
		printf("Yes\n");
	}
	else{
		printf("No\n");
	}
	inorder(T);
	printf("\n");//晕死。。。。 
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值