1119 Pre- and Post-order Traversals (30 分)已知先序和后序求中序

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

题意:给出⼀一棵树的结点个数n,以及它的前序遍历和后序遍历,输出它的中序遍历,如果中序遍历不不唯⼀一就输出No,且输出其中⼀一个中序即可,如果中序遍历唯⼀一就输出Yes,并输出它的中序
思路:⽤unique标记是否唯⼀,如果为true就表示中序是唯⼀的~
已知⼆叉树的前序和后序是无法唯⼀确定⼀颗⼆叉树的,因为可能会存在多种情况,这种情况就是一个结点可能是根的左孩⼦子也有可能是根的右孩⼦子,如果发现了⼀个无法确定的态,置unique =false,又因为题目只需要输出⼀个方案,可以假定这个不可确定的孩子的状态是右孩子,接下来的问题是如何求根结点和左右孩子划分的问题了,⾸首先我们需要知道树的表示范围,需要四个变量,分别是前序的开始的地方prel,前序结束的地方prer,后序开始的地方postl,后序结束的地方postr,前序的开始的第⼀个应该是后序的最后一个是相等的,这个结点就是根结点,以后序的根结点的前⾯面一个结点作为参考,寻找这个结点在前序的位置,就可以根据这个位置来划分左右孩子,递归处理理。

#include<iostream>
#include<cstdio>
#include<stack> 
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<cctype>
#include<cstdlib>
#include<ctime>
#include<unordered_map>

using namespace std;

vector<int> pre,in,post;
bool uniqu = true;

void getin(int prel,int prer,int postl,int postr) {
	if(prel == prer) {
		in.push_back(pre[prel]);
		return;
	}	
	if(pre[prel] == post[postr]) {
		int i = prel + 1;
		while(i <= prer && pre[i] != post[postr - 1]) {
			i++;
		}
		if(i - prel > 1) {
			getin(prel + 1,i - 1,postl,postl + (i - prel - 1) - 1);
		}
		else {
			uniqu = false;
		}
		in.push_back(post[postr]);
		getin(i, prer, postl + (i - prel - 1), postr - 1);
	}
}

int main() {
	int n;
	scanf("%d", &n);
	pre.resize(n), post.resize(n);
	for (int i = 0; i < n; i++) {
		scanf("%d", &pre[i]);
	}
	for (int i = 0; i < n; i++) {
		scanf("%d", &post[i]);
	}
	getin(0, n-1, 0, n-1);
	printf("%s\n%d", uniqu == true ? "Yes" : "No", in[0]);
	for (int i = 1; i < in.size(); i++) {
		printf(" %d", in[i]);
	}
	printf("\n");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值