PAT——1119 Pre- and Post-order Traversals (30 分)(给定先序和后序序列,判断能否构建一颗唯一的树)

1119 Pre- and Post-order Traversals (30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

思路:关键在于父节点是否有一个孩子:

  • 如果只有一个孩子,构建树不唯一
  • 如果有两个孩子或没有孩子,建树唯一
#include <iostream>
#include <stdio.h>
#include <queue>
#include <vector>
#include <string.h>
using namespace std;

int n;
int pre[31], post[31];
vector<int> in;
bool uniquee = true;

typedef struct binTree
{
    int data;
    binTree *l_child;
    binTree *r_child;
    binTree()
    {
        l_child = r_child = NULL;
    }
}binTree;

void input()
{
    cin >> n;
    for(int i = 0; i < n; i++)
    {
        cin >> pre[i];
    }
    for(int i = 0; i < n; i++)
        cin >> post[i];
}

binTree *create_one(int preL, int preR, int postL, int postR)
{
    if(preL > preR || postL > postR)
    {
        return NULL;
    }

    int data = pre[preL];
    binTree *root = new binTree();
    root->data = data;
    if(preL == preR)
    {
        root->l_child = NULL;
        root->r_child = NULL;
        return root;
    }
    if(preL + 1 == preR)
    {
        uniquee = false;
        root->l_child = NULL;
        root->r_child = create_one(preL+1, preR, postL, postR-1);
        return root;
    }
    /*查找左子树的结束坐标*/
    int left_data = pre[preL+1];//左根元素
    int i;
    for(i = postL; i <= postR-1; i++)
    {
        if(post[i] == left_data)
        {
            break;
        }
    }
    int left_len = i - postL + 1;
    root->l_child = create_one(preL+1, preL+left_len,postL, postL+left_len-1);
    root->r_child = create_one(preL+left_len+1, preR, postL+left_len, postR-1);
    return root;
}

void inorder(binTree *root)
{
    if(root == NULL)
        return;
    inorder(root->l_child);
    in.push_back(root->data);
    inorder(root->r_child);
}

int main()
{
    /*1119 Pre- and Post-order Traversals (30 分)*/
    #ifndef ONLINE_JUDGE
        freopen("test.txt", "r", stdin);
    #endif // ONLINE_JUDGE

    input();

    binTree *root = create_one(0, n-1, 0, n-1);

    if(uniquee)
        cout << "Yes"<<endl;
    else
        cout << "No"<<endl;

    inorder(root);
    cout << in[0];
    for(int i = 1; i < n; i++)
        cout <<" "<< in[i];
    cout <<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值