1066. Root of AVL Tree (25)


时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

    

    

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print ythe root of the resulting AVL tree in one line.

Sample Input 1:
5
88 70 61 96 120
Sample Output 1:
70
Sample Input 2:
7
88 70 61 96 120 90 65
Sample Output 2:
88

参照数据结构第二版(陈越)P139


#include<stdio.h>
#include<stdlib.h>
typedef struct Node *node;
struct Node{
	int data;
	int height;
	node left;
	node right;	
};

int max(int a,int b){
	return a>b?a:b;
}

int getheight(node T){  
    if(T){  
        int HL=getheight(T->left);  
        int HR=getheight(T->right);  
        int maxH=HL>HR?HL:HR;  
        return maxH+1;   
    }  
    else{  
        return 0;  
    }   
}  

node singleleftrotation(node A){
	node B=A->left;
	A->left=B->right;
	B->right=A;
	A->height=max(getheight(A->left),getheight(A->right))+1;
	B->height=max(getheight(B->left),A->height)+1;
	return B;
}

node singlerightrotation(node A){
	node B=A->right;
	A->right=B->left;
	B->left=A;
	A->height=max(getheight(A->left),getheight(A->right))+1;
	B->height=max(getheight(B->right),A->height)+1;
	return B;
}

node doubleleftrightrotation(node A){//左右双旋 
	A->left=singlerightrotation(A->left);
	return singleleftrotation(A);
}

node doublerightleftrotation(node A){//右左双旋 
	A->right=singleleftrotation(A->right);
	return singlerightrotation(A);
}

node insert(node T,int x){
	if(!T){
		T=(node)malloc(sizeof(struct Node));
		T->data=x;
		T->height=1;
		T->left=T->right=NULL;			
	}
	else if(x<T->data){
		T->left=insert(T->left,x);
		if(getheight(T->left)-getheight(T->right)==2){
			if(x<T->left->data){//左单旋 
				T=singleleftrotation(T);
			}
			else{
				T=doubleleftrightrotation(T);//左右双旋 
			}
		}
	}
	else if(x>T->data){
		T->right=insert(T->right,x);
		if(getheight(T->left)-getheight(T->right)==-2){
			if(x>T->right->data){
				T=singlerightrotation(T);
			}
			else{
				T=doublerightleftrotation(T);
			}
		}
	}
	T->height=max(getheight(T->left),getheight(T->right))+1; 
	return T;
}
int main(){
	int n,i,x;
	scanf("%d",&n);
	node T=NULL;
	for(i=0;i<n;i++){
		scanf("%d",&x);
		T=insert(T,x);
	}
	printf("%d",T->data);
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值