1071. Speech Patterns (25)


时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HOU, Qiming

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return '\n'. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:
Can1: "Can a can can a can?  It can!"
Sample Output:
can 5

参照上机指南P250


#include<stdio.h>
#include<iostream>
#include<string>
#include<map>
using namespace std;
map<string,int>cou;
int check(char c){
	if(c>='0'&&c<='9'){
		return 1;
	}
	if(c>='a'&&c<='z'){
		return 1;
	}
	if(c>='A'&&c<='Z'){
		return 1;
	}
	return 0;
}
int main(){
	int i=0;
	string str;
	getline(cin,str);
	int len=str.length();
	while(i<len){
		string word;
		while(i<len&&check(str[i])==0){//定位到有效单词 
			i++;
		}
		while(i<len&&check(str[i])==1){
			if(str[i]>='A'&&str[i]<='Z'){
				str[i]=str[i]+32;
			}
			word=word+str[i];
			i++;
		}
//		if(word!=""){
			if(cou.find(word)==cou.end()){
				cou[word]=1;
			}
			else{
				cou[word]++;
			}
//		}
//		while(i<len&&check(str[i])==0){
//			i++;
//		}		
	}
	map<string,int>::iterator it=cou.begin();
	int max=-1;
	string ans;
	for(;it!=cou.end();it++){
		if(it->second>max){
			max=it->second;
			ans=it->first;
		}
	}
	cout<<ans<<" "<<max<<endl;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值