1059. Prime Factors (25)

1059. Prime Factors (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HE, Qinming

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi's are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291

方法二更直接.。。。


方法一:

#include<stdio.h>
int p[100000]={0};
void findprime(){
	int i,j;
	for(i=2;i<100000;i++){
		for(j=i+i;j<100000;j=j+i){
			p[j]=1;
		}
	}
}
int main(){
	findprime();
	int n,i;
	int flag=0;
	scanf("%d",&n);
	if(n==1){
		printf("1=1");
	}
	else{
		printf("%d=",n);
		for(i=2;n>1;i++){
			int k=0;
			while(p[i]==0&&n%i==0){
				n=n/i;
				k++;
			}
			if(k!=0){
				if(flag){
					printf("*");
				}
				flag=1;
				printf("%d",i);
				if(k>=2){
					printf("^%d",k);
				}
			}
		}
	}
}


方法二:

#include<stdio.h>
//int p[100000]={0};
//void findprime(){
//	int i,j;
//	for(i=2;i<100000;i++){
//		for(j=i+i;j<100000;j=j+i){
//			p[j]=1;
//		}
//	}
//}
int main(){
//	findprime();
	int n,i;
	int flag=0;
	scanf("%d",&n);
	if(n==1){
		printf("1=1");
	}
	else{
		printf("%d=",n);
		for(i=2;n>1;i++){
			int k=0;
			while(n%i==0){
				n=n/i;
				k++;
			}
			if(k!=0){
				if(flag){
					printf("*");
				}
				flag=1;
				printf("%d",i);
				if(k>=2){
					printf("^%d",k);
				}
			}
		}
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值