1059 Prime Factors

1059 Prime Factors (25 分)

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p​1​​​k​1​​​​×p​2​​​k​2​​​​×⋯×p​m​​​k​m​​​​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p​1​​^k​1​​*p​2​​^k​2​​**p​m​​^k​m​​, where p​i​​'s are prime factors of N in increasing order, and the exponent k​i​​ is the number of p​i​​ -- hence when there is only one p​i​​, k​i​​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

解析:素数筛选,预处理一下就o了

#include<set>
#include<map>
#include<list>
#include<queue>
#include<deque>
#include<cmath>
#include<stack>
#include<cstdio>
#include<string>
#include<bitset>
#include<vector>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<bits/stdc++.h>
using namespace std;

#define e exp(1)
#define p acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b) {
	return b?gcd(b,a%b):a;
}

const int maxn=5e5+5;
int cnt=0;
int prime[maxn],f[maxn+5];
void init()
{
	for(int i=2; i<maxn; i++)
	{
		if(!f[i])
		{
			prime[cnt++]=i;
			for(int j=i; j<maxn; j+=i)
			{
				f[j]=1;
			}
		}
	}
}
int main()
{
	init();
	ll n;scanf("%lld",&n);
    printf("%lld=",n);
	if(n==1)
	{
		puts("1");
		return 0;
	}
	
	int count=0,flag=0;
	for(int i=0; i<cnt; i++)
	{
		if(n==1)break;
		if(n%prime[i]==0)
		{
			printf("%d",prime[i]);
			n/=prime[i];
			count=1;
			flag=0;
			while(n%prime[i]==0)
			{
				if(n==0)break;
				if(!flag)printf("^");
				
				n/=prime[i];
				count++;
				flag=1;
			}
			if(flag)printf("%d",count);
			
			if(n!=1)printf("*");
		}
		
	}
	puts("");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值