1015. Reversible Primes (20)

1015. Reversible Primes (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

#include<stdio.h>
#include<math.h>
int isprime(int x){
	if(x<=1)return 0;
	int i,n=(int)sqrt(x);
	for(i=2;i<=n;i++){
		if(x%i==0){
			return 0;
		}
	}
	return 1;
}

int reverse(int n,int d){   //!!!!!!!
	int sum=0;
	while(n){
		sum=sum*d+n%d;
		n=n/d;
	}
	return sum;
}
int main(){
	int n,d,i;
	while(scanf("%d",&n)){
		if(n<0)break;
		scanf("%d",&d);
		if(isprime(n)==0){
			printf("No\n");continue;
		}
		int ans=reverse(n,d);
		if(isprime(ans)){
			printf("Yes\n");
		}
		else{
			printf("No\n");
		}
	}
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值