PAT-A1015 Reversible Primes 题目内容及题解

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

题目大意

判断一个给定的数在某进制下的逆序和其本身是否均是质数,并输出结果。

解题思路

  1. 判断n是否为质数;
  2. 做逆序判断其逆序是否也为质数;
  3. 输出结果并返回0值。

代码

#include<stdio.h>
#include<math.h>

#define MAXN 20

int num[MAXN];
int isPrime(int n){
    int sqr,i;
    if(n<=1){
        return 0;
    }else{
        sqr=(int)sqrt(1.0*n);
        for(i=2;i<=sqr;i++){
            if(n%i==0){
                return 0;
            }
        }
    }
    return 1;
}

int Reverse(int n,int radix){
    int k=0,i=0,sum=0;
    do{
        num[k++]=n%radix;
        n/=radix;
    }while(n);
    while(i<k){
        sum=sum*radix+num[i++];
    }
    return sum;
}

int main(){
    int n,rad;
    while(1){
        scanf("%d",&n);
        if(n<0){
            break;
        }
        scanf("%d",&rad);
        if(isPrime(n)&&isPrime(Reverse(n,rad))){
            printf("Yes\n");
        }else{
            printf("No\n");
        }
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值