题目描述
It's a hot summer day out on the farm, and Farmer John is serving lemonade to
his NN cows! All NN cows (conveniently numbered 1…N1…N) like lemonade, but some
of them like it more than others. In particular, cow ii is willing to wait in a
line behind at most wiwi cows to get her lemonade. Right now all NN cows are
in the fields, but as soon as Farmer John rings his cowbell, the cows will
immediately descend upon FJ's lemonade stand. They will all arrive before he
starts serving lemonade, but no two cows will arrive at the same time.
Furthermore, when cow ii arrives, she will join the line if and only if there
are at most wiwi cows already in line. Farmer John wants to prepare some amount
of lemonade in advance, but he does not want to be wasteful. The number of cows
who join the line might depend on the order in which they arrive. Help him find
the minimum possible number of cows who join the line.
输入
The first line contains NN, and the second line contains the NN space-separated
integers w1,w2,…,wNw1,w2,…,wN. It is guaranteed that 1≤N≤1051≤N≤105, and that
0≤wi≤1090≤wi≤109 for each cow ii.
输出
Print the minimum possible number of cows who might join the line, among all
possible orders in which the cows might arrive.
样例输入
5
7 1 400 2 2
样例输出
3
来源
USACO 2018 Open Silver
满分代码:
#include<iostream>
#include<algorithm>
#include<stdio.h>
using namespace std;
bool cmp(int x,int y)
{
return x>y;
}
int main()
{
int a[100005],i,j,k,n,sum=0;
cin>>n;
for(i=0; i<n; i++)
{
cin>>a[i];
}
sort(a,a+n,cmp);
for(i=0; i<n; i++)
{
if(a[i]>=sum)
{
sum++;
}
else
{
break;
}
}
cout<<sum;
}
jzxx3460Lemonade Line
最新推荐文章于 2020-06-18 13:15:05 发布